blob: a9a046571fa1432cfdce432867af35821b93a667 [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001require libcap-ng.inc
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08002
Brad Bishop15ae2502019-06-18 21:44:24 -04003inherit lib_package autotools
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08004
Brad Bishop15ae2502019-06-18 21:44:24 -04005EXTRA_OECONF += "--without-python --without-python3"
Brad Bishop64c979e2019-11-04 13:55:29 -05006LDFLAGS_append_class-native = " -pthread"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007
Brad Bishop15ae2502019-06-18 21:44:24 -04008BBCLASSEXTEND = "native nativesdk"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009
10do_install_append() {
11 # Moving libcap-ng to base_libdir
12 if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then
13 mkdir -p ${D}/${base_libdir}/
14 mv -f ${D}${libdir}/libcap-ng.so.* ${D}${base_libdir}/
15 relpath=${@os.path.relpath("${base_libdir}", "${libdir}")}
16 ln -sf ${relpath}/libcap-ng.so.0.0.0 ${D}${libdir}/libcap-ng.so
17 fi
18}