Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "Miscellaneous utilities specific to Debian" |
| 2 | DESCRIPTION = "Provides a number of small utilities which are used \ |
| 3 | primarily by the installation scripts of Debian packages, although \ |
| 4 | you may use them directly. " |
| 5 | HOMEPAGE = "https://packages.debian.org/sid/debianutils" |
| 6 | BUGTRACKER = "https://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=debianutils;dist=unstable" |
| 7 | SECTION = "base" |
| 8 | LICENSE = "GPL-2.0-only & SMAIL_GPL" |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=74765f57ae5dd2b10ffbc39528d98753" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 10 | |
| 11 | SRC_URI = "git://salsa.debian.org/debian/debianutils.git;protocol=https;branch=master \ |
| 12 | " |
| 13 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 14 | SRCREV = "d49a78eb264c1b2ad3d0d6de8e1fb776bda9c943" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 15 | |
| 16 | inherit autotools update-alternatives |
| 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | |
| 20 | # Disable po4a (translated manpages) sub-directory, as that requires po4a to build |
| 21 | do_configure:prepend() { |
| 22 | sed -i -e 's:po4a::g' ${S}/Makefile.am |
| 23 | } |
| 24 | |
| 25 | |
| 26 | do_install:append() { |
| 27 | if [ "${base_bindir}" != "${bindir}" ]; then |
| 28 | # Debian places some utils into ${base_bindir} as does busybox |
| 29 | install -d ${D}${base_bindir} |
| 30 | for app in run-parts; do |
| 31 | mv ${D}${bindir}/$app ${D}${base_bindir}/$app |
| 32 | done |
| 33 | fi |
| 34 | } |
| 35 | |
| 36 | # Note that we package the update-alternatives name. |
| 37 | # |
| 38 | PACKAGES =+ "${PN}-run-parts" |
| 39 | FILES:${PN}-run-parts = "${base_bindir}/run-parts.debianutils" |
| 40 | |
| 41 | RDEPENDS:${PN} += "${PN}-run-parts" |
| 42 | RDEPENDS:${PN}:class-native = "" |
| 43 | |
| 44 | ALTERNATIVE_PRIORITY = "30" |
| 45 | ALTERNATIVE:${PN} = "add-shell installkernel remove-shell savelog which" |
| 46 | |
| 47 | ALTERNATIVE_PRIORITY_${PN}-run-parts = "60" |
| 48 | ALTERNATIVE:${PN}-run-parts = "run-parts" |
| 49 | |
| 50 | ALTERNATIVE:${PN}-doc = "which.1" |
| 51 | ALTERNATIVE_LINK_NAME[which.1] = "${mandir}/man1/which.1" |
| 52 | |
| 53 | ALTERNATIVE_LINK_NAME[add-shell] = "${sbindir}/add-shell" |
| 54 | ALTERNATIVE_LINK_NAME[installkernel] = "${sbindir}/installkernel" |
| 55 | ALTERNATIVE_LINK_NAME[remove-shell] = "${sbindir}/remove-shell" |
| 56 | ALTERNATIVE_LINK_NAME[run-parts] = "${base_bindir}/run-parts" |
| 57 | ALTERNATIVE_LINK_NAME[savelog] = "${bindir}/savelog" |
| 58 | ALTERNATIVE_LINK_NAME[which] = "${bindir}/which" |
| 59 | |
| 60 | BBCLASSEXTEND = "native" |