blob: 915277b42cf8ee96f0b947c91b86d36e83dd24b6 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Miscellaneous utilities specific to Debian"
2DESCRIPTION = "Provides a number of small utilities which are used \
3primarily by the installation scripts of Debian packages, although \
4you may use them directly. "
5HOMEPAGE = "https://packages.debian.org/sid/debianutils"
6BUGTRACKER = "https://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=debianutils;dist=unstable"
7SECTION = "base"
8LICENSE = "GPL-2.0-only & SMAIL_GPL"
Andrew Geissler8f840682023-07-21 09:09:43 -05009LIC_FILES_CHKSUM = "file://debian/copyright;md5=74765f57ae5dd2b10ffbc39528d98753"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000010
11SRC_URI = "git://salsa.debian.org/debian/debianutils.git;protocol=https;branch=master \
12 "
13
Andrew Geissler220dafd2023-10-04 10:18:08 -050014SRCREV = "d49a78eb264c1b2ad3d0d6de8e1fb776bda9c943"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000015
16inherit autotools update-alternatives
17
18S = "${WORKDIR}/git"
19
20# Disable po4a (translated manpages) sub-directory, as that requires po4a to build
21do_configure:prepend() {
22 sed -i -e 's:po4a::g' ${S}/Makefile.am
23}
24
25
26do_install:append() {
27 if [ "${base_bindir}" != "${bindir}" ]; then
28 # Debian places some utils into ${base_bindir} as does busybox
29 install -d ${D}${base_bindir}
30 for app in run-parts; do
31 mv ${D}${bindir}/$app ${D}${base_bindir}/$app
32 done
33 fi
34}
35
36# Note that we package the update-alternatives name.
37#
38PACKAGES =+ "${PN}-run-parts"
39FILES:${PN}-run-parts = "${base_bindir}/run-parts.debianutils"
40
41RDEPENDS:${PN} += "${PN}-run-parts"
42RDEPENDS:${PN}:class-native = ""
43
44ALTERNATIVE_PRIORITY = "30"
45ALTERNATIVE:${PN} = "add-shell installkernel remove-shell savelog which"
46
47ALTERNATIVE_PRIORITY_${PN}-run-parts = "60"
48ALTERNATIVE:${PN}-run-parts = "run-parts"
49
50ALTERNATIVE:${PN}-doc = "which.1"
51ALTERNATIVE_LINK_NAME[which.1] = "${mandir}/man1/which.1"
52
53ALTERNATIVE_LINK_NAME[add-shell] = "${sbindir}/add-shell"
54ALTERNATIVE_LINK_NAME[installkernel] = "${sbindir}/installkernel"
55ALTERNATIVE_LINK_NAME[remove-shell] = "${sbindir}/remove-shell"
56ALTERNATIVE_LINK_NAME[run-parts] = "${base_bindir}/run-parts"
57ALTERNATIVE_LINK_NAME[savelog] = "${bindir}/savelog"
58ALTERNATIVE_LINK_NAME[which] = "${bindir}/which"
59
60BBCLASSEXTEND = "native"