blob: 33266be69d55a81dc8de828b7abeb5ccdc6540a3 [file] [log] [blame]
Brad Bishop65b40a82016-06-09 22:22:46 -04001# In general this class should only be used by board layers
2# that keep their machine-readable-workbook in the skeleton repository.
3
4inherit allarch
5inherit setuptools
6
7SRC_URI += "git://github.com/openbmc/skeleton;subpath=configs"
8S = "${WORKDIR}/configs"
9
10python() {
11 machine = d.getVar('MACHINE', True).capitalize() + '.py'
12 d.setVar('_config_in_skeleton', machine)
13}
14
15do_make_setup() {
16 cp ${S}/${_config_in_skeleton} \
17 ${S}/obmc_system_config.py
18 cat <<EOF > ${S}/setup.py
19from distutils.core import setup
20
21setup(name='${BPN}',
22 version='${PR}',
23 py_modules=['obmc_system_config'],
24 )
25EOF
26}
27
28addtask make_setup after do_patch before do_configure