blob: 7ea03ccd1a85a2b502ee4cb53daae8e18c51e31c [file] [log] [blame]
Vijay Khemkaefc72a02018-11-20 11:14:07 -08001SUMMARY = "dbus-sensors"
2DESCRIPTION = "Dbus Sensor Services Configured from D-Bus"
3
4SRC_URI = "git://github.com/openbmc/dbus-sensors.git"
Andrew Geisslere55311c2019-01-31 18:22:15 +00005SRCREV = "2a408b946e7107426e4ec19f19782cae04fceab8"
Vijay Khemkaefc72a02018-11-20 11:14:07 -08006
7PV = "0.1+git${SRCPV}"
8
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
11
12SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.fansensor.service"
13SYSTEMD_SERVICE_${PN} += " xyz.openbmc_project.adcsensor.service"
14SYSTEMD_SERVICE_${PN} += " xyz.openbmc_project.hwmontempsensor.service"
15SYSTEMD_SERVICE_${PN} += " xyz.openbmc_project.cpusensor.service"
James Feistaac4f702018-12-12 09:40:58 -080016SYSTEMD_SERVICE_${PN} += " xyz.openbmc_project.exitairsensor.service"
James Feist65b507d2019-01-30 10:15:41 -080017SYSTEMD_SERVICE_${PN} += " xyz.openbmc_project.ipmbsensor.service"
Vijay Khemkaefc72a02018-11-20 11:14:07 -080018
19DEPENDS = "boost nlohmann-json sdbusplus"
20inherit cmake systemd
21
22S = "${WORKDIR}/git/"
23
24# linux-libc-headers guides this way to include custom uapi headers
25CXXFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include/uapi"
26CXXFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include"
27do_configure[depends] += "virtual/kernel:do_shared_workdir"
28EXTRA_OECMAKE = "-DYOCTO=1"