blob: 22fd0f48e2aa28cbd83483f99d8366f68cbf45c2 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Gesture Recognition And Instantiation Library"
2
3HOMEPAGE = "https://launchpad.net/grail"
4
5LICENSE = "GPLv3 & LGPLv3"
6LIC_FILES_CHKSUM = " \
7 file://COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02 \
8 file://COPYING.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
9"
10
11inherit autotools pkgconfig
12
13DEPENDS = "frame"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014CXXFLAGS_append_toolchain-clang = " -Wno-pessimizing-move"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050015SRC_URI = "https://launchpad.net/${BPN}/trunk/${PV}/+download/${BPN}-${PV}.tar.bz2"
Patrick Williamsddad1a12017-02-23 20:36:32 -060016SRC_URI[md5sum] = "0df1b3ec6167920f310e2effe6e2ad44"
17SRC_URI[sha256sum] = "5eed1f650f042481daa3a2de5e7d43261fe343b2a1b1e240f3b7fc26572c9df3"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050018
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050020PACKAGECONFIG[x11] = "--with-x11, --without-x11, libxi"
21
22PACKAGE_BEFORE_PN += "${PN}-test"
23FILES_${PN}-test = "${bindir}/grail-test*"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050024SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"