Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Tool to display and modify PXA registers at runtime" |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://pxaregs.c;endline=12;md5=668d061b7637acc68cb8071c9be372e6" |
| 4 | AUTHOR = "Holger Schurig <hs4233@mail.mn-solutions.de>" |
| 5 | HOMEPAGE = "http://www.mn-logistik.de/unsupported/pxa250/" |
| 6 | |
| 7 | SRC_URI = "file://pxaregs.c \ |
| 8 | file://i2c.patch \ |
| 9 | file://munmap.patch \ |
| 10 | file://serial.patch \ |
| 11 | file://usb.patch " |
| 12 | |
| 13 | S = "${WORKDIR}" |
| 14 | |
| 15 | do_compile() { |
| 16 | ${CC} pxaregs.c -o pxaregs ${CFLAGS} ${LDFLAGS} |
| 17 | } |
| 18 | |
| 19 | do_install() { |
| 20 | install -d ${D}${sbindir}/ |
| 21 | install -m 0755 pxaregs ${D}${sbindir}/ |
| 22 | } |
| 23 | |
| 24 | SRC_URI[md5sum] = "a43baa88842cd5926dbffb6fb87624f6" |
| 25 | SRC_URI[sha256sum] = "f339b91cd8ab348052c36b36d20033e4bffc3666bc836ff72d5704f025e1c057" |