blob: 8e328d846f2fdece04ec4f5d2bf44e89b1a41212 [file] [log] [blame]
Brad Bishop2f63e8c2017-01-28 13:00:52 -05001SUMMARY = "Palmetto IPMI to DBus Inventory mapping."
2PR = "r1"
Brad Bishop6738f352018-11-07 13:04:06 -08003LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
Brad Bishop2f63e8c2017-01-28 13:00:52 -05005
6inherit native
Brad Bishop2f63e8c2017-01-28 13:00:52 -05007inherit phosphor-ipmi-fru
8
9SRC_URI += "file://config.yaml"
10
11PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
12
13S = "${WORKDIR}"
14
15do_install() {
16 # TODO: install this to inventory_datadir
17 # after ipmi-fru-parser untangles the host
18 # firmware config from the machine inventory.
19 DEST=${D}${config_datadir}
20
21 install -d ${DEST}
22 install config.yaml ${DEST}
23}
24