blob: c0620ff5d1e3e38aee7dbe29a8fdef905ceb7664 [file] [log] [blame]
Brad Bishopac1ae1f2017-02-09 15:08:05 -05001SUMMARY = "Romulus IPMI to DBus Inventory mapping."
2PR = "r1"
Brad Bishop6738f352018-11-07 13:04:06 -08003LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
Brad Bishopac1ae1f2017-02-09 15:08:05 -05005
6inherit native
Brad Bishopac1ae1f2017-02-09 15:08:05 -05007inherit phosphor-ipmi-fru
8
9SRC_URI += "file://config.yaml"
10
11PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
12
13S = "${WORKDIR}"
14
15do_install() {
16 # TODO: install this to inventory_datadir
17 # after ipmi-fru-parser untangles the host
18 # firmware config from the machine inventory.
19 DEST=${D}${config_datadir}
20
21 install -d ${DEST}
22 install config.yaml ${DEST}
23}
24