Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "ExtUtils::ParseXS - converts Perl XS code into C code" |
| 2 | DESCRIPTION = "\"ExtUtils::ParseXS\" will compile XS code into C code by \ |
| 3 | embedding the constructs necessary to let C functions manipulate Perl \ |
| 4 | values and creates the glue necessary to let Perl access those functions. \ |
| 5 | The compiler uses typesmapes to determine how to map C function parameters \ |
| 6 | and variables to Perl values." |
| 7 | |
| 8 | SECTION = "libs" |
| 9 | |
| 10 | HOMEPAGE = "http://metapan.org/release/ExtUtils-ParseXS/" |
| 11 | |
| 12 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 13 | LIC_FILES_CHKSUM = "file://README;beginline=120;endline=129;md5=eb858f0e3b1b0bee0c05b86a474ae2b6" |
| 14 | |
| 15 | SRCNAME = "ExtUtils-ParseXS" |
| 16 | SRC_URI = "${CPAN_MIRROR}/authors/id/S/SM/SMUELLER/${SRCNAME}-${PV}.tar.gz" |
| 17 | SRC_URI[md5sum] = "2ae41036d85e98e1369645724962dd16" |
| 18 | SRC_URI[sha256sum] = "41def0511278a2a8ba9afa25ccab45b0453f75e7fd774e8644b5f9a57cc4ee1c" |
| 19 | |
| 20 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 21 | |
| 22 | inherit cpan |
| 23 | |
| 24 | RDEPENDS_${PN} = " perl-module-carp \ |
| 25 | perl-module-cwd \ |
| 26 | perl-module-dynaloader \ |
| 27 | perl-module-extutils-cbuilder \ |
| 28 | perl-module-extutils-makemaker \ |
| 29 | perl-module-file-basename \ |
| 30 | perl-module-file-spec \ |
| 31 | perl-module-lib \ |
| 32 | perl-module-symbol \ |
| 33 | perl-module-test-more \ |
| 34 | " |
| 35 | |
| 36 | RPROVIDES_${PN} += " libextutils-parsexs-constants-perl \ |
| 37 | libextutils-parsexs-countlines-perl \ |
| 38 | libextutils-parsexs-eval-perl \ |
| 39 | libextutils-parsexs-utilities-perl \ |
| 40 | libextutils-typemaps-perl \ |
| 41 | libextutils-typemaps-cmd-perl \ |
| 42 | libextutils-typemaps-inputmap-perl \ |
| 43 | libextutils-typemaps-outputmap-perl \ |
| 44 | libextutils-typemaps-type-perl \ |
| 45 | " |
| 46 | |
| 47 | BBCLASSEXTEND = "native" |