blob: 53960d6e34cc0bc7d14b15a001ac6857e5d866e5 [file] [log] [blame]
Ed Tanous132c0962018-05-31 15:07:49 -07001SUMMARY = "Phosphor OpenBMC KCS to DBUS"
2DESCRIPTION = "Phosphor OpenBMC KCS to DBUS."
Brad Bishopb3f2d732018-12-04 20:00:20 +00003LICENSE = "Apache-2.0"
Ed Tanous132c0962018-05-31 15:07:49 -07004LIC_FILES_CHKSUM = "file://LICENSE;md5=b1beb00e508e89da1ed2a541934f28c0"
Ed Tanous132c0962018-05-31 15:07:49 -07005DEPENDS += " \
William A. Kennington IIIf64e0fd2021-05-27 18:52:38 -07006 fmt \
Vernon Mauery03f22ad2019-04-12 14:06:06 -07007 sdbusplus \
William A. Kennington IIIf64e0fd2021-05-27 18:52:38 -07008 sdeventplus \
9 stdplus \
10 systemd \
Ed Tanous132c0962018-05-31 15:07:49 -070011 "
Ed Tanous9936f862022-09-19 09:13:20 -070012PROVIDES += "virtual/obmc-host-ipmi-hw"
Andrew Geissler97677122023-10-24 18:30:22 -050013SRCREV = "9a324232f9ff9f26e97f101cbb1f272fe7e2d20b"
Ed Tanous9936f862022-09-19 09:13:20 -070014PV = "1.0+git${SRCPV}"
15PR = "r1"
16
17SRC_URI = "git://github.com/openbmc/kcsbridge.git;branch=master;protocol=https"
18
19SYSTEMD_SERVICE:${PN} = "${PN}@${KCS_DEVICE}.service"
20S = "${WORKDIR}/git"
21
22inherit meson pkgconfig
23inherit systemd
24
25RRECOMMENDS:${PN} += "phosphor-ipmi-host"
26
27RPROVIDES:${PN} += "virtual-obmc-host-ipmi-hw"
28
29FILES:${PN} += "${systemd_system_unitdir}/${PN}@.service"
30
31KCS_DEVICE ?= "ipmi-kcs3"