blob: 5de59d5b45d583444075ba0b24dca8cc92bd75c1 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "Colored terminal output for Python's logging module"
2HOMEPAGE = "https://coloredlogs.readthedocs.io"
3SECTION = "devel/python"
4LICENSE = "MIT"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05005LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=764e737b117a38d773609885e8d04f0b"
Andrew Geissler82c905d2020-04-13 13:39:40 -05006
Andrew Geissler69721092021-07-23 12:57:00 -04007SRC_URI[sha256sum] = "7c991aa71a4577af2f82600d8f8f3a89f936baeaf9b50a9c197da014e5bf16b0"
Andrew Geissler82c905d2020-04-13 13:39:40 -05008
9inherit pypi setuptools3
10
11do_compile_prepend() {
12 sed -ie "s/find_pth_directory(),/'',/g" ${S}/setup.py
13}
14
15do_install_append() {
16 rm -rf ${D}${datadir}
17}
18
19RDEPENDS_${PN} += "\
20 ${PYTHON_PN}-humanfriendly \
21"
22
23BBCLASSEXTEND = "native"