blob: 596d16fa4af7509523e387ea18460d0d0763c9c7 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A drop-in replacement for argparse that allows options to also be set via config files and/or environment variables."
2HOMEPAGE = "https://github.com/bw2/ConfigArgParse"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=da746463714cc35999ed9a42339f2943"
5
Andrew Geissler69721092021-07-23 12:57:00 -04006SRC_URI[sha256sum] = "371f46577e76ec71a183b88378f36dd09f4b946f60fe60712f411b020f26b812"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007
8PYPI_PACKAGE = "ConfigArgParse"
9
10inherit pypi setuptools3
11
12PACKAGECONFIG ?= "yaml"
13PACKAGECONFIG[yaml] = ",,,${PYTHON_PN}-pyyaml"
14
15RDEPENDS_${PN} += "\
16 ${PYTHON_PN}-core \
17 ${PYTHON_PN}-shell \
Andrew Geissler69721092021-07-23 12:57:00 -040018 ${PYTHON_PN}-json \
Andrew Geissler82c905d2020-04-13 13:39:40 -050019"
20
21BBCLASSEXTEND = "native nativesdk"