blob: 1b62a7611f7ce22800f7f2d44805bbcf9b452291 [file] [log] [blame]
Andrew Geissler69721092021-07-23 12:57:00 -04001# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Get CPU info with pure Python 2 & 3"
5HOMEPAGE = "https://github.com/workhorsy/py-cpuinfo"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=b0b97c022f12b14d9e02de0b283ee9e9"
8
9SRC_URI[sha256sum] = "5f269be0e08e33fd959de96b34cd4aeeeacac014dd8305f70eb28d06de2345c5"
10
11inherit ptest pypi setuptools3
12
13SRC_URI += "file://run-ptest \
14 "
15
16do_install_ptest() {
17 install -d ${D}${PTEST_PATH}/tests
18 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
19}
20
21RDEPENDS_${PN}-ptest += "\
22 python3-pytest \
23"
24
25RDEPENDS_${PN} += "python3-core python3-ctypes python3-datetime python3-json python3-io python3-mmap python3-multiprocessing python3-netclient python3-pickle python3-pprint python3-shell"
26
27BBCLASSEXTEND = "native nativesdk"