blob: 4721b4b321535df276a7ac81010e30e6d7bc7b39 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Perl module for reading and writing XML"
2DESCRIPTION = "The XML::Simple Perl module provides a simple API layer \
3on top of an underlying XML parsing module to maintain XML files \
4(especially configuration files). It is a blunt rewrite of XML::Simple \
5(by Grant McLean) to use the XML::LibXML parser for XML structures, \
6where the original uses plain Perl or SAX parsers."
7HOMEPAGE = "http://search.cpan.org/~markov/XML-LibXML-Simple-0.93/lib/XML/LibXML/Simple.pod"
8SECTION = "libs"
9LICENSE = "Artistic-1.0 | GPL-1.0+"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=e7dbb3e2241fac8457967053fc1a1ddb"
11DEPENDS += "libxml-parser-perl"
12
13SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Simple-${PV}.tar.gz"
14
15SRC_URI[md5sum] = "4d10964e123b76eca36678464daa63cd"
16SRC_URI[sha256sum] = "5cff13d0802792da1eb45895ce1be461903d98ec97c9c953bc8406af7294434a"
17
18S = "${WORKDIR}/XML-Simple-${PV}"
19
20EXTRA_PERLFLAGS = "-I ${PERLHOSTLIB}"
21
22inherit cpan
23
24BBCLASSEXTEND = "native"