blob: 1cdecb07c5e7882fd34df1be49f1021f975f567c [file] [log] [blame]
Artem Senichev8574e7e2020-05-08 12:33:35 +03001SUMMARY = "Command-line interface"
2DESCRIPTION = "YADRO OpenBMC Command Line Interface for end users"
3HOMEPAGE = "https://github.com/YADRO-KNS/obmc-yadro-cli"
4PR = "r1"
5PV = "1.0+git${SRCPV}"
6
7# License info
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
10
11# Dependencies
12DEPENDS = "phosphor-user-manager"
Alexander Filippov69f2c782020-10-27 16:01:14 +030013RDEPENDS_${PN} = " \
14 ${VIRTUAL-RUNTIME_base-utils} \
15 bash \
16 obmc-console \
17 obmc-yadro-fwupdate \
18 obmc-yadro-lssensors \
19 obmc-yadro-netconfig \
20 sudo \
21 systemd \
22"
23# Some platforms also require some additional packages like
24# ipmitool, obmc-yadro-lsinventory, obmc-yadro-backup ...
25# They should be appended by bbappend file in their layers
Artem Senichev8574e7e2020-05-08 12:33:35 +030026
Alexander Filippovad7324a2020-09-30 12:59:16 +030027# Directory with command handlers
28FILES_${PN} += "${datadir}/cli"
Artem Senichev8574e7e2020-05-08 12:33:35 +030029
30# Custom installation procedure
31do_install() {
32 ${B}/install.sh \
33 --dir ${D} \
Alexander Filippovad7324a2020-09-30 12:59:16 +030034 --machine ${@'${MACHINE}'.split('-')[0]} \
Artem Senichev8574e7e2020-05-08 12:33:35 +030035 --admin priv-admin \
36 --operator priv-operator \
37 --user priv-user
38}
39
40# Source code repository
41S = "${WORKDIR}/git"
42SRC_URI = "git://github.com/YADRO-KNS/obmc-yadro-cli"
Alexander Filippov69f2c782020-10-27 16:01:14 +030043SRCREV = "9457a085c86722214d6c450397ccecd6db4a1071"