blob: d2b3f6b33695e19e790b15c2f7d7f5e27b345f70 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Binary used to test smack tcp sockets"
2DESCRIPTION = "Server and client binaries used to test smack attributes on TCP sockets"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6SRC_URI = "file://tcp_server.c \
7 file://tcp_client.c \
8 file://test_smack_tcp_sockets.sh \
9"
10
11S = "${WORKDIR}"
12
13do_compile() {
14 ${CC} tcp_client.c ${LDFLAGS} -o tcp_client
15 ${CC} tcp_server.c ${LDFLAGS} -o tcp_server
16}
17
18do_install() {
19 install -d ${D}${bindir}
20 install -d ${D}${sbindir}
21 install -m 0755 tcp_server ${D}${bindir}
22 install -m 0755 tcp_client ${D}${bindir}
23 install -m 0755 test_smack_tcp_sockets.sh ${D}${sbindir}
24}