blob: 9193f8989942f5512225665bebd48f4c4842c878 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Binary used to test smack udp sockets"
2DESCRIPTION = "Server and client binaries used to test smack attributes on UDP sockets"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6SRC_URI = "file://udp_server.c \
7 file://udp_client.c \
8 file://test_smack_udp_sockets.sh \
9"
10
11S = "${WORKDIR}"
12do_compile() {
13 ${CC} udp_client.c ${LDFLAGS} -o udp_client
14 ${CC} udp_server.c ${LDFLAGS} -o udp_server
15}
16
17do_install() {
18 install -d ${D}${bindir}
19 install -d ${D}${sbindir}
20 install -m 0755 udp_server ${D}${bindir}
21 install -m 0755 udp_client ${D}${bindir}
22 install -m 0755 test_smack_udp_sockets.sh ${D}${sbindir}
23}