blob: 3cfc1bc58e83bc107b160b4f83a72330bd032190 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4HOMEPAGE = "https://lttng.org/"
5LICENSE = "LGPL-2.1-only & GPL-2.0-only & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=0464cff101a009c403cd2ed65d01d4c4"
7
8inherit module
9
10include lttng-platforms.inc
11
Patrick Williams03907ee2022-05-01 06:28:52 -050012SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
Patrick Williams03907ee2022-05-01 06:28:52 -050013 file://0009-Rename-genhd-wrapper-to-blkdev.patch \
Patrick Williamsb9af8752023-01-30 13:28:01 -060014 file://fix-jbd2-use-the-correct-print-format-v5.10.163.patch \
15 file://fix-jbd2-upper-bound-for-v5.10.163.patch \
Andrew Geissler615f2f12022-07-15 14:00:58 -050016 "
Patrick Williams03907ee2022-05-01 06:28:52 -050017
Andrew Geissler9aee5002022-03-30 16:27:02 +000018# Use :append here so that the patch is applied also when using devupstream
19SRC_URI:append = " file://0001-src-Kbuild-change-missing-CONFIG_TRACEPOINTS-to-warn.patch"
20
Andrew Geisslerc5535c92023-01-27 16:10:19 -060021SRC_URI[sha256sum] = "f525d3d48ea3a475cb535339c201666d0e4c75ec8c46d29837bcf381ea02cb19"
Andrew Geissler9aee5002022-03-30 16:27:02 +000022
23export INSTALL_MOD_DIR="kernel/lttng-modules"
24
25EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
26
27MODULES_MODULE_SYMVERS_LOCATION = "src"
28
29do_install:append() {
30 # Delete empty directories to avoid QA failures if no modules were built
31 if [ -d ${D}/${nonarch_base_libdir} ]; then
32 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
33 fi
34}
35
36python do_package:prepend() {
37 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
38 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
39}
40
41BBCLASSEXTEND = "devupstream:target"
42SRC_URI:class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.13"
43SRCREV:class-devupstream = "7584cfc04914cb0842a986e9808686858b9c8630"
44SRCREV_FORMAT ?= "lttng_git"