blob: 342661c9a5b43dee149c41a08c03c9fa3156e4ae [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Tool to access UFS (Universal Flash Storage) devices"
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "GPL-2.0-only"
Brad Bishope42b3e32020-01-15 22:08:42 -05003LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
4
Brad Bishope42b3e32020-01-15 22:08:42 -05005BRANCH ?= "dev"
6
Andrew Geissler6aa7eec2023-03-03 12:41:14 -06007SRCREV = "40c0bdfa7f4e922a4bcdf431ef72b321648d2d9f"
Brad Bishope42b3e32020-01-15 22:08:42 -05008
Andrew Geissler595f6302022-01-24 19:11:47 +00009SRC_URI = "git://github.com/westerndigitalcorporation/ufs-utils.git;protocol=https;branch=${BRANCH} \
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060010 "
Brad Bishope42b3e32020-01-15 22:08:42 -050011
Andrew Geissler82c905d2020-04-13 13:39:40 -050012UPSTREAM_CHECK_COMMITS = "1"
13
Brad Bishope42b3e32020-01-15 22:08:42 -050014S = "${WORKDIR}/git"
15
16EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} CC="${CC}" CFLAGS="${CFLAGS}""
17
Patrick Williams213cb262021-08-07 19:21:33 -050018CFLAGS:append:mipsarchn64 = " -D__SANE_USERSPACE_TYPES__ -D_GNU_SOURCE"
Brad Bishope42b3e32020-01-15 22:08:42 -050019
20do_configure() {
21 sed -i -e "s|-static$||g" ${S}/Makefile
22}
23
24do_install() {
25 install -D -m 755 ${S}/ufs-utils ${D}${bindir}/ufs-utils
26}
27
28PROVIDES += "ufs-tool"
29
Patrick Williams213cb262021-08-07 19:21:33 -050030RPROVIDES:${PN} += "ufs-tool"
Brad Bishope42b3e32020-01-15 22:08:42 -050031