blob: cc3f2ee1dda15e7fa0c6bbe5ef639e60f20008a4 [file] [log] [blame]
William A. Kennington IIIb95905d2021-06-02 12:40:56 -07001SUMMARY = "Network scanning and manipulation tool"
2DESCRIPTION = "Scapy is a powerful interactive packet manipulation program. \
3It is able to forge or decode packets of a wide number of protocols, send \
4them on the wire, capture them, match requests and replies, and much more. \
5It can easily handle most classical tasks like scanning, tracerouting, probing, \
6unit tests, attacks or network discovery (it can replace hping, 85% of nmap, \
7arpspoof, arp-sk, arping, tcpdump, tethereal, p0f, etc.). It also performs very \
8well at a lot of other specific tasks that most other tools can't handle, like \
9sending invalid frames, injecting your own 802.11 frames, combining technics \
10(VLAN hopping+ARP cache poisoning, VOIP decoding on WEP encrypted channel, ...), etc."
11SECTION = "security"
Andrew Geissler9aee5002022-03-30 16:27:02 +000012LICENSE = "GPL-2.0-only"
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070013
14LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
15
16# If you want ptest support, use the git repo
17# UTscapy does not exist in the pypi pkg
18#
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060019SRCREV = "9473f77d8b548c8e478e52838bdd4c12f5d4f4ff"
Andrew Geissler595f6302022-01-24 19:11:47 +000020SRC_URI = "git://github.com/secdev/scapy.git;branch=master;protocol=https \
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070021 file://run-ptest"
22
23S = "${WORKDIR}/git"
24
25UPSTREAM_CHECK_COMMITS = "1"
26
27inherit setuptools3 ptest
28
Patrick Williams213cb262021-08-07 19:21:33 -050029do_install:append() {
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070030 mv ${D}${bindir}/scapy ${D}${bindir}/scapy3
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070031}
32
33do_install_ptest() {
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060034 install -m 0644 ${S}/scapy/tools/UTscapy.py ${D}${PTEST_PATH}
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070035 install -m 0644 ${S}/test/regression.uts ${D}${PTEST_PATH}
36 sed -i 's,@PTEST_PATH@,${PTEST_PATH},' ${D}${PTEST_PATH}/run-ptest
37}
38
Patrick Williams213cb262021-08-07 19:21:33 -050039RDEPENDS:${PN} = "tcpdump ${PYTHON_PN}-compression ${PYTHON_PN}-cryptography ${PYTHON_PN}-netclient \
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070040 ${PYTHON_PN}-netserver ${PYTHON_PN}-pydoc ${PYTHON_PN}-pkgutil ${PYTHON_PN}-shell \
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060041 ${PYTHON_PN}-threading ${PYTHON_PN}-numbers ${PYTHON_PN}-fcntl"