blob: a6ba671e703c50eb0959e3c0435830e7ab7b2cec [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Enhanced NetBSD ftp client"
2DESCRIPTION = "tnftp (formerly known as lukemftp) is a port of the NetBSD FTP client \
3to other systems. It offers many enhancements over the traditional \
4BSD FTP client, including command-line editing, command-line fetches \
5of FTP and HTTP URLs (including via proxies), command-line uploads of \
6FTP URLs, context-sensitive word completion, dynamic progress bar, \
7IPv6 support, modification time preservation, paging of local and \
8remote files, passive mode support (with fallback to active mode), \
9SOCKS support, TIS FWTK gate-ftp server support, and transfer rate \
10throttling."
11
12SECTION = "net"
13LICENSE = "BSD-4-Clause"
14
15DEPENDS = "ncurses"
16
17SRC_URI = "ftp://ftp.netbsd.org/pub/NetBSD/misc/tnftp/${BPN}-${PV}.tar.gz \
18 file://0001-libedit-Include-missing-header-stdc-predef.h.patch \
19"
20
21inherit autotools update-alternatives pkgconfig
22
23ALTERNATIVE_PRIORITY = "100"
24
25ALTERNATIVE:${PN} = "ftp"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060026ALTERNATIVE_LINK_NAME[ftp] = "${bindir}/ftp"
27ALTERNATIVE_TARGET[ftp] = "${bindir}/tnftp"
Andrew Geissler595f6302022-01-24 19:11:47 +000028
29FILES:${PN} = "${bindir}/tnftp"
30
31LIC_FILES_CHKSUM = "file://COPYING;md5=b4248c6fb8ecff27f256ba97b25f1a21"
32SRC_URI[md5sum] = "fdb6dd1b53dca79148c395b77c6dba5a"
33SRC_URI[sha256sum] = "101901e90b656c223ec8106370dd0d783fb63d26aa6f0b2a75f40e86a9f06ea2"
34
35PACKAGECONFIG ?= "openssl \
36 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
37"
38PACKAGECONFIG[openssl] = "--enable-ssl, --disable-ssl --with-ssl=no, openssl"
39PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"