blob: 4e1edc6ceffc3ede25cf2441edea7742fc51f6e3 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Trace and analyze execution of a program written in C/C++"
2HOMEPAGE = "https://github.com/namhyung/uftrace"
3BUGTRACKER = "https://github.com/namhyung/uftrace/issues"
4SECTION = "devel"
Andrew Geissler9aee5002022-03-30 16:27:02 +00005LICENSE = "GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00006LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8DEPENDS = "elfutils"
9DEPENDS:append:libc-musl = " argp-standalone"
10
11inherit autotools
12
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060013SRCREV = "be3f46f7656bd9243b1835337b5350247b030b02"
14SRC_URI = "git://github.com/namhyung/${BPN};branch=master;protocol=https"
Andrew Geissler595f6302022-01-24 19:11:47 +000015S = "${WORKDIR}/git"
16
17LDFLAGS:append:libc-musl = " -largp"
18
19def set_target_arch(d):
20 import re
21 arch = d.getVar('TARGET_ARCH')
22 if re.match(r'i.86', arch, re.I):
23 return 'i386'
24 elif re.match('armeb', arch, re.I):
25 return 'arm'
26 else:
27 return arch
28
29EXTRA_UFTRACE_OECONF = "ARCH=${@set_target_arch(d)} \
30 with_elfutils=/use/libelf/from/sysroot"
31
32do_configure() {
33 ${S}/configure ${EXTRA_UFTRACE_OECONF}
34}
35
36FILES_SOLIBSDEV = ""
37FILES:${PN} += "${libdir}/*.so"
38
39COMPATIBLE_HOST = "(i.86|x86_64|aarch64|arm)"
40
41# uftrace supports armv6 and above
42COMPATIBLE_HOST:armv4 = 'null'
43COMPATIBLE_HOST:armv5 = 'null'