blob: 7a71d02dc1858dd8293eeaf6ad2d88ba056e04f3 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Data recovery tool"
2DESCRIPTION = "GNU ddrescue is a data recovery tool. It copies data \
3 from one file or block device (hard disc, cdrom, etc) to another, \
4 trying hard to rescue data in case of read errors."
5HOMEPAGE = "http://www.gnu.org/software/ddrescue/ddrescue.html"
6SECTION = "console"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007LICENSE = "GPL-2.0-or-later"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00008
9LIC_FILES_CHKSUM = "file://COPYING;md5=76d6e300ffd8fb9d18bd9b136a9bba13 \
10 file://main_common.cc;beginline=5;endline=16;md5=ad099df052bdd8297f490712285069da \
11 "
12
13SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.lz"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060014SRC_URI[sha256sum] = "38c80c98c5a44f15e53663e4510097fd68d6ec20758efdf3a925037c183232eb"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000015
16# This isn't already added by base.bbclass
17do_unpack[depends] += "lzip-native:do_populate_sysroot"
18
19CONFIGUREOPTS = "\
20 '--srcdir=${S}' \
21 '--prefix=${prefix}' \
22 '--exec-prefix=${exec_prefix}' \
23 '--bindir=${bindir}' \
24 '--datadir=${datadir}' \
25 '--infodir=${infodir}' \
26 '--sysconfdir=${sysconfdir}' \
27 'CXX=${CXX}' \
28 'CPPFLAGS=${CPPFLAGS}' \
29 'CXXFLAGS=${CXXFLAGS}' \
30 'LDFLAGS=${LDFLAGS}' \
31"
32EXTRA_OEMAKE = ""
33
34do_configure () {
35 ${S}/configure ${CONFIGUREOPTS}
36}
37
38do_install () {
39 oe_runmake 'DESTDIR=${D}' install
40 # Info dir listing isn't interesting at this point so remove it if it exists.
41 if [ -e "${D}${infodir}/dir" ]; then
42 rm -f ${D}${infodir}/dir
43 fi
44}