blob: 3aafa3f0d2341c1b3dfb35c8ccc94d8a76ed1743 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Desktop containment framework."
2HOMEPAGE = "http://flatpak.org"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
5
6SRC_URI = " \
7 gitsm://github.com/flatpak/flatpak;protocol=https;nobranch=1 \
8 file://0001-flatpak-pc-add-pc_sysrootdir.patch \
9"
10
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060011SRCREV = "756994b5c433dad9786f9fad736667c4f524aeac"
Andrew Geissler517393d2023-01-13 08:55:19 -060012
13S = "${WORKDIR}/git"
14
15inherit meson pkgconfig gettext systemd gobject-introspection python3native useradd mime features_check
16
17REQUIRED_DISTRO_FEATURES = "polkit"
18
19DEPENDS = " \
20 appstream \
21 bison-native \
22 curl \
23 dconf \
24 fuse3 \
25 gdk-pixbuf \
26 glib-2.0 \
27 gpgme \
28 json-glib \
29 libarchive \
30 libcap \
31 libxslt-native \
32 ostree \
33 polkit \
34 python3-pyparsing-native \
35 xmlto-native \
36"
37
38RDEPENDS:${PN} = " \
39 bubblewrap \
40 ca-certificates \
41 dconf \
42 flatpak-xdg-utils \
43"
44
45GIR_MESON_OPTION = ""
46
47PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,xauth"
48PACKAGECONFIG[xauth] = "-Dxauth=enabled,-Dxauth=disabled,xauth"
49PACKAGECONFIG[seccomp] = "-Dseccomp=enabled,-Dseccomp=disabled,libseccomp"
50
51PACKAGECONFIG ?= " \
52 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xauth', '', d)} \
53 ${@bb.utils.contains('DISTRO_FEATURES', 'security', 'seccomp', '', d)} \
54"
55
56FILES:${PN} += "${libdir} ${datadir}"
57
58USERADD_PACKAGES = "${PN}"
59USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 polkitd"
60
61do_install:append() {
62 chmod 0700 ${D}/${datadir}/polkit-1/rules.d
63 chown polkitd ${D}/${datadir}/polkit-1/rules.d
64 chgrp root ${D}/${datadir}/polkit-1/rules.d
65}