blob: f7039b5916716bcd8bd5aac5998b80d093a952d9 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "The Geolocation Service"
2DESCRIPTION = "Geoclue is a D-Bus service that provides location information. \
3The primary goal of the Geoclue project is to make creating location-aware applications \
4as simple as possible, while the secondary goal is to ensure that no application \
5can access location information without explicit permission from user."
6LICENSE = "GPL-2.0-or-later"
7SECTION = "console/network"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=bdfdd4986a0853eb84eeba85f9d0c4d6"
10
11DEPENDS = "glib-2.0 dbus json-glib libsoup-3.0 intltool-native"
12
13inherit meson pkgconfig gtk-doc gobject-introspection vala useradd
14
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060015SRCREV = "bbfb6289dedb88cb8155d9f6868787d5432e1f90"
Andrew Geissler517393d2023-01-13 08:55:19 -060016SRC_URI = "git://gitlab.freedesktop.org/geoclue/geoclue.git;protocol=https;nobranch=1"
17
18S = "${WORKDIR}/git"
19
20# Without this line, package is declared a library and named libgeoclue*
21AUTO_LIBNAME_PKGS = ""
22
23PACKAGECONFIG ??= "3g modem-gps cdma nmea lib"
24PACKAGECONFIG[3g] = "-D3g-source=true,-D3g-source=false,modemmanager"
25PACKAGECONFIG[modem-gps] = "-Dmodem-gps-source=true,-Dmodem-gps-source=false,modemmanager"
26PACKAGECONFIG[cdma] = "-Dcdma-source=true,-Dcdma-source=false,modemmanager"
27PACKAGECONFIG[nmea] = "-Dnmea-source=true,-Dnmea-source=false,avahi,avahi-daemon"
28PACKAGECONFIG[lib] = "-Dlibgeoclue=true,-Dlibgeoclue=false,gobject-introspection"
29
30GTKDOC_MESON_OPTION = "gtk-doc"
31
32EXTRA_OEMESON += " \
33 -Ddbus-sys-dir=${sysconfdir}/dbus-1/system.d \
34 -Ddemo-agent=false \
35"
36
37USERADD_PACKAGES = "${PN}"
38USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 --shell /bin/nologin polkitd"
39
40do_install:append() {
41 if ${@bb.utils.contains('PACKAGECONFIG', 'modem-gps', 'true', 'false', d)}; then
42 # Fix up permissions on polkit rules.d to work with rpm4 constraints
43 chmod 700 ${D}/${datadir}/polkit-1/rules.d
44 chown polkitd:root ${D}/${datadir}/polkit-1/rules.d
45 fi
46}
47
48FILES:${PN} += " \
49 ${datadir}/dbus-1/system-services \
50 ${datadir}/polkit-1/rules.d \
51 ${libdir} \
52 ${systemd_unitdir} \
53 ${prefix}/libexec \
54"
55
56FILES:${PN}-dev += " \
57 ${datadir}/dbus-1/interfaces \
58 ${datadir}/gir-1.0 \
59"