blob: 07ab283755b4d62e21a5371286f4d9f16e67dc52 [file] [log] [blame]
Andrew Geissler6aa7eec2023-03-03 12:41:14 -06001DESCRIPTION = "A file format designed for highly efficient deltas while maintaining good compression"
2AUTHOR = "Jonathan Dieter"
3
4LICENSE = "BSD-2-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=daf6e68539f564601a5a5869c31e5242"
6
7SRC_URI = "git://github.com/zchunk/zchunk.git;protocol=https;branch=main"
8
9SRCREV = "1d8f14484b4e0b507487abe6c294fb2059b7b72f"
10S = "${WORKDIR}/git"
11
12DEPENDS = "zstd"
13DEPENDS:append:libc-musl = " argp-standalone"
14
15inherit meson pkgconfig lib_package
16
17PACKAGECONFIG ??= "openssl zckdl"
18
19# zckdl gets packaged into zchunk-bin
20PACKAGECONFIG[zckdl] = "-Dwith-curl=enabled,-Dwith-curl=disabled,curl"
21# Use OpenSSL primitives for SHA
22PACKAGECONFIG[openssl] = "-Dwith-openssl=enabled,-Dwith-openssl=disabled,openssl"
23
24BBCLASSEXTEND = "native nativesdk"