blob: 29d790b94f36d5f895e17cff24d5cb977d77a1fd [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Extra features for standard library's cmd module"
2HOMEPAGE = "https://github.com/python-cmd2/cmd2"
3LICENSE = "MIT"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -06004LIC_FILES_CHKSUM = "file://LICENSE;md5=fad7740aa21780c8b9a214f5b320b4ad"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005
6DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
7
Andrew Geissler6aa7eec2023-03-03 12:41:14 -06008SRC_URI[sha256sum] = "71873c11f72bd19e2b1db578214716f0d4f7c8fa250093c601265a9a717dee52"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00009
10inherit pypi setuptools3
11
12RDEPENDS:${PN} += "\
13 ${PYTHON_PN}-attrs \
14 ${PYTHON_PN}-colorama \
15 ${PYTHON_PN}-pyperclip \
16 ${PYTHON_PN}-wcwidth \
17 ${PYTHON_PN}-compression \
18 ${PYTHON_PN}-pydoc \
19 ${PYTHON_PN}-json \
20 ${PYTHON_PN}-numbers \
21"
22
23BBCLASSEXTEND = "native nativesdk"