blob: 90c56c75a42580394e6e6b9c1597c01e789e671e [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "A microframework based on Werkzeug, Jinja2 and good intentions"
2DESCRIPTION = "\
3Flask is a microframework for Python based on Werkzeug, Jinja 2 and good \
4intentions. And before you ask: It’s BSD licensed!"
5HOMEPAGE = "https://github.com/mitsuhiko/flask/"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
8
Andrew Geissler6aa7eec2023-03-03 12:41:14 -06009SRC_URI[sha256sum] = "7eb373984bf1c770023fce9db164ed0c3353cd0b53f130f4693da0ca756a2e6d"
Patrick Williams92b42cb2022-09-03 06:53:57 -050010
11PYPI_PACKAGE = "Flask"
12
13inherit pypi setuptools3
14
15CLEANBROKEN = "1"
16
17RDEPENDS:${PN} = " \
18 ${PYTHON_PN}-werkzeug \
19 ${PYTHON_PN}-jinja2 \
20 ${PYTHON_PN}-itsdangerous \
21 ${PYTHON_PN}-click \
22 ${PYTHON_PN}-profile \
23"