blob: aa8dfe279d007d07b94c093704545c26f5564ac1 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "pandas library for high-performance data analysis tools"
2DESCRIPTION = "pandas is an open source, BSD-licensed library providing \
3high-performance, easy-to-use data structures and data analysis tools for \
4the Python programming language."
5HOMEPAGE = "http://pandas.pydata.org/"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=c1cc9ab35a8b2aabf933cd6d245b5db3"
8
Andrew Geissler6aa7eec2023-03-03 12:41:14 -06009SRC_URI[sha256sum] = "74a3fd7e5a7ec052f183273dc7b0acd3a863edf7520f5d3a1765c04ffdb3b0b1"
Andrew Geissler517393d2023-01-13 08:55:19 -060010
11inherit pypi setuptools3
12
13DEPENDS += " \
14 ${PYTHON_PN}-numpy-native ${PYTHON_PN}-cython-native \
15"
16
17CFLAGS:append:toolchain-clang = " -Wno-error=deprecated-declarations"
18
19RDEPENDS:${PN} += " \
20 ${PYTHON_PN}-json \
21 ${PYTHON_PN}-numpy \
22 ${PYTHON_PN}-dateutil \
23 ${PYTHON_PN}-dateutil-zoneinfo \
24 ${PYTHON_PN}-pytz \
25 ${PYTHON_PN}-profile \
26"