blob: 980b6d965bf2c6f9b2f794c632c1ec9876d99f03 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Python project template generator with batteries included"
2DESCRIPTION = "PyScaffold package helps to setup a new Python project. \
3After installation, it provides a new command [putup], which could be \
4used to create template Projects."
5
6HOMEPAGE = "https://github.com/pyscaffold/pyscaffold"
7SECTION = "devel/python"
8LICENSE = "0BSD & MIT"
9LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=14a49c74a1d91829908ac756c07e6b91"
10DEPENDS += "python3-setuptools-scm-native"
11
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060012SRC_URI[sha256sum] = "94088d129b61cd9b4b4607c6a466759b1bb2ada36206d5ac20aa319edcc5d701"
Andrew Geissler9aee5002022-03-30 16:27:02 +000013
14inherit pypi python_setuptools_build_meta
15PYPI_PACKAGE = "PyScaffold"
16
17RDEPENDS:${PN} += " \
18 python3-email \
19 python3-compression \
20"
21
22BBCLASSEXTEND = "native nativesdk"