blob: a088fef41981f3fbe49ef6f82e86398b37206956 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "RISC-V Open Source Supervisor Binary Interface (OpenSBI)"
2DESCRIPTION = "OpenSBI aims to provide an open-source and extensible implementation of the RISC-V SBI specification for a platform specific firmware (M-mode) and a general purpose OS, hypervisor or bootloader (S-mode or HS-mode). OpenSBI implementation can be easily extended by RISC-V platform or System-on-Chip vendors to fit a particular hadware configuration."
3HOMEPAGE = "https://github.com/riscv/opensbi"
4LICENSE = "BSD-2-Clause"
5LIC_FILES_CHKSUM = "file://COPYING.BSD;md5=42dd9555eb177f35150cf9aa240b61e5"
6
7require opensbi-payloads.inc
8
9inherit autotools-brokensep deploy
10
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060011SRCREV = "6b5188ca14e59ce7bf71afe4e7d3d557c3d31bf8"
Andrew Geissler615f2f12022-07-15 14:00:58 -050012SRC_URI = "git://github.com/riscv/opensbi.git;branch=master;protocol=https"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000013
14S = "${WORKDIR}/git"
15
16EXTRA_OEMAKE += "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= "
17# If RISCV_SBI_PAYLOAD is set then include it as a payload
18EXTRA_OEMAKE:append = " ${@riscv_get_extra_oemake_image(d)}"
19EXTRA_OEMAKE:append = " ${@riscv_get_extra_oemake_fdt(d)}"
20
21# Required if specifying a custom payload
22do_compile[depends] += "${@riscv_get_do_compile_depends(d)}"
23
24do_install:append() {
25 # In the future these might be required as a dependency for other packages.
26 # At the moment just delete them to avoid warnings
27 rm -r ${D}/include
28 rm -r ${D}/lib*
29 rm -r ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/payloads
30}
31
32do_deploy () {
33 install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_payload.* ${DEPLOYDIR}/
34 install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_jump.* ${DEPLOYDIR}/
35 install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_dynamic.* ${DEPLOYDIR}/
36}
37
38addtask deploy before do_build after do_install
39
40FILES:${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_jump.*"
41FILES:${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_payload.*"
42FILES:${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_dynamic.*"
43
44COMPATIBLE_HOST = "(riscv64|riscv32).*"
45INHIBIT_PACKAGE_STRIP = "1"
46
47SECURITY_CFLAGS = ""