blob: c7610d440c1a5bee914045ee82b627d0472ccff3 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Simple powerful testing with python"
2HOMEPAGE = "https://pypi.org/project/pytest/"
3DESCRIPTION = "The pytest framework makes it easy to write small tests, yet scales to support complex functional testing for applications and libraries."
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=bd27e41b6550fe0fc45356d1d81ee37c"
7
Patrick Williams864cc432023-02-09 14:54:44 -06008SRC_URI[sha256sum] = "d45e0952f3727241918b8fd0f376f5ff6b301cc0777c6f9a556935c92d8a7d42"
Andrew Geissler9aee5002022-03-30 16:27:02 +00009
10DEPENDS += "python3-setuptools-scm-native"
11
12inherit update-alternatives pypi python_setuptools_build_meta
13
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060014RDEPENDS:${PN} += " \
Andrew Geissler9aee5002022-03-30 16:27:02 +000015 ${PYTHON_PN}-atomicwrites \
16 ${PYTHON_PN}-attrs \
17 ${PYTHON_PN}-debugger \
18 ${PYTHON_PN}-doctest \
19 ${PYTHON_PN}-importlib-metadata \
20 ${PYTHON_PN}-iniconfig \
21 ${PYTHON_PN}-json \
22 ${PYTHON_PN}-more-itertools \
23 ${PYTHON_PN}-packaging \
24 ${PYTHON_PN}-pathlib2 \
25 ${PYTHON_PN}-pluggy \
26 ${PYTHON_PN}-py \
27 ${PYTHON_PN}-setuptools \
28 ${PYTHON_PN}-six \
Andrew Geissler9aee5002022-03-30 16:27:02 +000029 ${PYTHON_PN}-wcwidth \
30"
31
32ALTERNATIVE:${PN} += "py.test pytest"
33
34NATIVE_LINK_NAME[pytest] = "${bindir}/pytest"
35ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest"
36
37ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test"
38ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test"
39
40BBCLASSEXTEND = "native nativesdk"