blob: 120ee80b177de003a01574b145c8cd74cf0f7a18 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "A thin layer of graphic data types"
2HOMEPAGE = "http://ebassi.github.io/graphene/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a7d871d9e23c450c421a85bb2819f648"
5
6GNOMEBASEBUILDCLASS = "meson"
7
8inherit gnomebase gobject-introspection gtk-doc
9
10SRC_URI[archive.sha256sum] = "a37bb0e78a419dcbeaa9c7027bcff52f5ec2367c25ec859da31dfde2928f279a"
11
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060012# Disable neon support by default on ARM-32 platforms because of the
13# following upstream bug: https://github.com/ebassi/graphene/issues/215
14PACKAGECONFIG ?= "${@bb.utils.contains('TUNE_FEATURES', 'aarch64', 'neon', '', d)}"
15
16PACKAGECONFIG[neon] = "-Darm_neon=true,-Darm_neon=false,"
17
18GIR_MESON_ENABLE_FLAG = 'enabled'
19GIR_MESON_DISABLE_FLAG = 'disabled'
Andrew Geissler517393d2023-01-13 08:55:19 -060020
21GTKDOC_MESON_OPTION = "gtk_doc"
22
23EXTRA_OEMESON = "-Dinstalled_tests=false"
24
25FILES:${PN} += "${libdir}/graphene-1.0"
26
27BBCLASSEXTEND = "native nativesdk"