blob: 2daecc9856b0e5b4604f34c77efc67b17affb54f [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Weston, a Wayland compositor"
2DESCRIPTION = "Weston is the reference implementation of a Wayland compositor"
3HOMEPAGE = "http://wayland.freedesktop.org"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d79ee9e66bb0f95d3386a7acae780b70 \
6 file://libweston/compositor.c;endline=27;md5=eb6d5297798cabe2ddc65e2af519bcf0 \
7 "
8
9SRC_URI = "https://gitlab.freedesktop.org/wayland/weston/uploads/f5648c818fba5432edc3ea63c4db4813/${BPN}-${PV}.tar.xz \
10 file://weston.png \
11 file://weston.desktop \
12 file://xwayland.weston-start \
13 file://systemd-notify.weston-start \
14 "
15
16SRC_URI[sha256sum] = "a413f68c252957fc3191c3650823ec356ae8c124ccc0cb440da5cdc4e2cb9e57"
17
18UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"
19UPSTREAM_CHECK_REGEX = "weston-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)"
20
21inherit meson pkgconfig useradd
22
23# depends on virtual/egl
24#
25require ${THISDIR}/required-distro-features.inc
26
27DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0"
28DEPENDS += "wayland wayland-protocols libinput virtual/egl pango wayland-native"
29
30LDFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'lto', '-Wl,-z,undefs', '', d)}"
31
32WESTON_MAJOR_VERSION = "${@'.'.join(d.getVar('PV').split('.')[0:1])}"
33
34EXTRA_OEMESON += "-Dpipewire=false"
35
36PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms wayland egl clients', '', d)} \
37 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland', '', d)} \
38 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd x11', d)} \
39 ${@bb.utils.contains_any('DISTRO_FEATURES', 'wayland x11', '', 'headless', d)} \
40 ${@oe.utils.conditional('VIRTUAL-RUNTIME_init_manager', 'sysvinit', 'launcher-libseat', '', d)} \
41 image-jpeg \
42 screenshare \
43 shell-desktop \
44 shell-fullscreen \
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060045 shell-ivi \
46 shell-kiosk \
47 "
Andrew Geissler517393d2023-01-13 08:55:19 -060048
49# Can be 'damage', 'im', 'egl', 'shm', 'touch', 'dmabuf-feedback', 'dmabuf-v4l', 'dmabuf-egl' or 'all'
50SIMPLECLIENTS ?= "all"
51
52#
53# Compositor choices
54#
55# Weston on KMS
56PACKAGECONFIG[kms] = "-Dbackend-drm=true,-Dbackend-drm=false,drm udev virtual/egl virtual/libgles2 virtual/libgbm mtdev"
57# Weston on Wayland (nested Weston)
58PACKAGECONFIG[wayland] = "-Dbackend-wayland=true,-Dbackend-wayland=false,virtual/egl virtual/libgles2"
59# Weston on X11
60PACKAGECONFIG[x11] = "-Dbackend-x11=true,-Dbackend-x11=false,virtual/libx11 libxcb libxcb libxcursor cairo"
61# Headless Weston
62PACKAGECONFIG[headless] = "-Dbackend-headless=true,-Dbackend-headless=false"
63# Weston on RDP
64PACKAGECONFIG[rdp] = "-Dbackend-rdp=true,-Dbackend-rdp=false,freerdp"
65# VA-API desktop recorder
66PACKAGECONFIG[vaapi] = "-Dbackend-drm-screencast-vaapi=true,-Dbackend-drm-screencast-vaapi=false,libva"
67# Weston with EGL support
68PACKAGECONFIG[egl] = "-Drenderer-gl=true,-Drenderer-gl=false,virtual/egl"
69# Weston with lcms support
70PACKAGECONFIG[lcms] = "-Dcolor-management-lcms=true,-Dcolor-management-lcms=false,lcms"
71# Weston with webp support
72PACKAGECONFIG[webp] = "-Dimage-webp=true,-Dimage-webp=false,libwebp"
73# Weston with systemd-login support
74PACKAGECONFIG[systemd] = "-Dsystemd=true -Dlauncher-logind=true,-Dsystemd=false -Dlauncher-logind=false,systemd dbus"
75# Weston with Xwayland support (requires X11 and Wayland)
76PACKAGECONFIG[xwayland] = "-Dxwayland=true,-Dxwayland=false"
77# colord CMS support
78PACKAGECONFIG[colord] = "-Ddeprecated-color-management-colord=true,-Ddeprecated-color-management-colord=false,colord"
79# Clients support
80PACKAGECONFIG[clients] = "-Dsimple-clients=${SIMPLECLIENTS} -Ddemo-clients=true,-Dsimple-clients= -Ddemo-clients=false"
81# Virtual remote output with GStreamer on DRM backend
82PACKAGECONFIG[remoting] = "-Dremoting=true,-Dremoting=false,gstreamer1.0 gstreamer1.0-plugins-base"
83# Weston with screen-share support
84PACKAGECONFIG[screenshare] = "-Dscreenshare=true,-Dscreenshare=false"
85# Traditional desktop shell
86PACKAGECONFIG[shell-desktop] = "-Dshell-desktop=true,-Dshell-desktop=false"
87# Fullscreen shell
88PACKAGECONFIG[shell-fullscreen] = "-Dshell-fullscreen=true,-Dshell-fullscreen=false"
89# In-Vehicle Infotainment (IVI) shell
90PACKAGECONFIG[shell-ivi] = "-Dshell-ivi=true,-Dshell-ivi=false"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060091# Kiosk shell
92PACKAGECONFIG[shell-kiosk] = "-Dshell-kiosk=true,-Dshell-kiosk=false"
Andrew Geissler517393d2023-01-13 08:55:19 -060093# JPEG image loading support
94PACKAGECONFIG[image-jpeg] = "-Dimage-jpeg=true,-Dimage-jpeg=false, jpeg"
95# support libseat based launch
96PACKAGECONFIG[launcher-libseat] = "-Dlauncher-libseat=true,-Dlauncher-libseat=false,seatd"
97
98do_install:append() {
99 # Weston doesn't need the .la files to load modules, so wipe them
100 rm -f ${D}/${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.la
101
102 # If X11, ship a desktop file to launch it
103 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" ]; then
104 install -d ${D}${datadir}/applications
105 install ${WORKDIR}/weston.desktop ${D}${datadir}/applications
106
107 install -d ${D}${datadir}/icons/hicolor/48x48/apps
108 install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps
109 fi
110
111 if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then
112 install -Dm 644 ${WORKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland
113 fi
114
115 if [ "${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'yes', 'no', d)}" = "yes" ]; then
116 install -Dm 644 ${WORKDIR}/systemd-notify.weston-start ${D}${datadir}/weston-start/systemd-notify
117 fi
118
119 if [ "${@bb.utils.contains('PACKAGECONFIG', 'launch', 'yes', 'no', d)}" = "yes" ]; then
120 chmod u+s ${D}${bindir}/weston-launch
121 fi
122}
123
124PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', '${PN}-xwayland', '', d)} \
125 libweston-${WESTON_MAJOR_VERSION} ${PN}-examples"
126
127FILES:${PN}-dev += "${libdir}/${BPN}/libexec_weston.so"
128FILES:${PN} = "${bindir}/weston ${bindir}/weston-terminal ${bindir}/weston-info ${bindir}/weston-launch ${bindir}/wcap-decode ${libexecdir} ${libdir}/${BPN}/*.so* ${datadir}"
129
130FILES:libweston-${WESTON_MAJOR_VERSION} = "${libdir}/lib*${SOLIBS} ${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.so"
131SUMMARY:libweston-${WESTON_MAJOR_VERSION} = "Helper library for implementing 'wayland window managers'."
132
133FILES:${PN}-examples = "${bindir}/*"
134
135FILES:${PN}-xwayland = "${libdir}/libweston-${WESTON_MAJOR_VERSION}/xwayland.so"
136RDEPENDS:${PN}-xwayland += "xwayland"
137
138RDEPENDS:${PN} += "xkeyboard-config"
139RRECOMMENDS:${PN} = "weston-init liberation-fonts"
140RRECOMMENDS:${PN}-dev += "wayland-protocols"
141
142USERADD_PACKAGES = "${PN}"
143GROUPADD_PARAM:${PN} = "--system weston-launch"