blob: 4ab8451c60feb46f7b2f949bd1805d5144a406ea [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Device Tree Compiler"
2HOMEPAGE = "https://devicetree.org/"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -06003DESCRIPTION = "The Device Tree Compiler is a toolchain for working with device tree source and binary files."
Andrew Geissler595f6302022-01-24 19:11:47 +00004SECTION = "bootloader"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "GPL-2.0-only | BSD-2-Clause"
Brad Bishop79641f22019-09-10 07:20:22 -04006
7LIC_FILES_CHKSUM = "file://GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
Andrew Geissler6aa7eec2023-03-03 12:41:14 -06008 file://BSD-2-Clause;md5=5d6306d1b08f8df623178dfd81880927 \
9 file://README.license;md5=a1eb22e37f09df5b5511b8a278992d0e"
Brad Bishop79641f22019-09-10 07:20:22 -040010
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060011SRC_URI = "git://git.kernel.org/pub/scm/utils/dtc/dtc.git;branch=main"
12SRCREV = "039a99414e778332d8f9c04cbd3072e1dcc62798"
Andrew Geissler90fd73c2021-03-05 15:25:55 -060013
Andrew Geissler595f6302022-01-24 19:11:47 +000014UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
15
Brad Bishop79641f22019-09-10 07:20:22 -040016S = "${WORKDIR}/git"
17
Andrew Geissler595f6302022-01-24 19:11:47 +000018inherit meson pkgconfig
19
20EXTRA_OEMESON = "-Dpython=disabled -Dvalgrind=disabled"
21
22PACKAGECONFIG ??= "tools"
23PACKAGECONFIG[tools] = "-Dtools=true,-Dtools=false,flex-native bison-native"
24PACKAGECONFIG[yaml] = "-Dyaml=enabled,-Dyaml=disabled,libyaml"
25
26PACKAGES =+ "${PN}-misc"
27FILES:${PN}-misc = "${bindir}/convert-dtsv0 ${bindir}/ftdump ${bindir}/dtdiff"
28RDEPENDS:${PN}-misc += "${@bb.utils.contains('PACKAGECONFIG', 'tools', 'bash diffutils', '', d)}"
29
Brad Bishop79641f22019-09-10 07:20:22 -040030BBCLASSEXTEND = "native nativesdk"