blob: e63e1c8367dcc4157e0c9471767f207afc2053de [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "General-purpose library specifically developed for the WPE-flavored port of WebKit."
2HOMEPAGE = "https://github.com/WebPlatformForEmbedded/libwpe"
3BUGTRACKER = "https://github.com/WebPlatformForEmbedded/libwpe/issues"
4
5LICENSE = "BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://COPYING;md5=371a616eb4903c6cb79e9893a5f615cc"
7DEPENDS = "virtual/egl libxkbcommon"
8
9inherit cmake features_check pkgconfig
10
11REQUIRED_DISTRO_FEATURES = "opengl"
12
13SRC_URI = "https://wpewebkit.org/releases/${BPN}-${PV}.tar.xz"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060014SRC_URI[sha256sum] = "b1d0cdcf0f8dbb494e65b0f7913e357106da9a0d57f4fbb7b9d1238a6dbe9ade"
Patrick Williams92b42cb2022-09-03 06:53:57 -050015
16# This is a tweak of upstream-version-is-even needed because
17# ipstream directory contains tarballs for other components as well.
18UPSTREAM_CHECK_REGEX = "libwpe-(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)\.tar"