blob: e52920883a04c330165b94cf2706bd836353adac [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "https://www.webkitgtk.org/"
3BUGTRACKER = "https://bugs.webkit.org/"
4
5LICENSE = "BSD-2-Clause & LGPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
7 file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \
8 file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
9 file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
10 "
11
12SRC_URI = "https://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
13 file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
14 file://reproducibility.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060015 file://0d3344e17d258106617b0e6d783d073b188a2548.patch \
Patrick Williamsb9af8752023-01-30 13:28:01 -060016 file://d318bb461f040b90453bc4e100dcf967243ecd98.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060017 "
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060018SRC_URI[sha256sum] = "40c20c43022274df5893f22b1054fa894c3eea057389bb08aee08c5b0bb0c1a7"
Andrew Geissler517393d2023-01-13 08:55:19 -060019
20inherit cmake pkgconfig gobject-introspection perlnative features_check upstream-version-is-even gi-docgen
21
22ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
23REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'opengl', '', d)}"
24
25CVE_PRODUCT = "webkitgtk webkitgtk\+"
26
Andrew Geisslerc5535c92023-01-27 16:10:19 -060027DEPENDS += " \
Andrew Geissler517393d2023-01-13 08:55:19 -060028 ruby-native \
29 gperf-native \
30 cairo \
31 harfbuzz \
32 jpeg \
33 atk \
34 libwebp \
35 gtk+3 \
36 libxslt \
37 libtasn1 \
38 libnotify \
39 gstreamer1.0 \
40 gstreamer1.0-plugins-base \
41 "
42
43PACKAGECONFIG_SOUP ?= "soup3"
44PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd wayland x11', d)} \
45 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'webgl opengl', '', d)} \
46 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'webgl gles2', d)} \
47 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl-or-es', '', d)} \
48 enchant \
49 libsecret \
50 ${PACKAGECONFIG_SOUP} \
51 "
52
53PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland libwpe wpebackend-fdo wayland-native"
54PACKAGECONFIG[angle] = "-DUSE_ANGLE_WEBGL=ON,-DUSE_ANGLE_WEBGL=OFF"
55PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11 libxcomposite libxdamage libxrender libxt"
56PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue"
57PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant2"
58PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2"
59PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/egl"
60PACKAGECONFIG[opengl] = "-DENABLE_GRAPHICS_CONTEXT_GL=ON,-DENABLE_GRAPHICS_CONTEXT_GL=OFF,virtual/egl"
61PACKAGECONFIG[opengl-or-es] = "-DUSE_OPENGL_OR_ES=ON,-DUSE_OPENGL_OR_ES=OFF"
62PACKAGECONFIG[libsecret] = "-DUSE_LIBSECRET=ON,-DUSE_LIBSECRET=OFF,libsecret"
63PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
64PACKAGECONFIG[woff2] = "-DUSE_WOFF2=ON,-DUSE_WOFF2=OFF,woff2"
65PACKAGECONFIG[openjpeg] = "-DUSE_OPENJPEG=ON,-DUSE_OPENJPEG=OFF,openjpeg"
66PACKAGECONFIG[systemd] = "-DUSE_SYSTEMD=ON,-DUSE_SYSTEMD=off,systemd"
67PACKAGECONFIG[reduce-size] = "-DCMAKE_BUILD_TYPE=MinSizeRel,-DCMAKE_BUILD_TYPE=Release,,"
68PACKAGECONFIG[lcms] = "-DUSE_LCMS=ON,-DUSE_LCMS=OFF,lcms"
69PACKAGECONFIG[soup2] = "-DUSE_SOUP2=ON,-DUSE_SOUP2=OFF,libsoup-2.4,,,soup3"
70PACKAGECONFIG[soup3] = ",,libsoup,,,soup2"
71PACKAGECONFIG[journald] = "-DENABLE_JOURNALD_LOG=ON,-DENABLE_JOURNALD_LOG=OFF,systemd"
72
73# webkitgtk is full of /usr/bin/env python, particular for generating docs
74do_configure[postfuncs] += "setup_python_link"
75setup_python_link() {
76 if [ ! -e ${STAGING_BINDIR_NATIVE}/python ]; then
77 ln -s `which python3` ${STAGING_BINDIR_NATIVE}/python
78 fi
79}
80
81EXTRA_OECMAKE = " \
82 -DPORT=GTK \
83 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
84 ${@bb.utils.contains('GIDOCGEN_ENABLED', 'True', '-DENABLE_DOCUMENTATION=ON', '-DENABLE_DOCUMENTATION=OFF', d)} \
85 -DENABLE_MINIBROWSER=ON \
86 -DPYTHON_EXECUTABLE=`which python3` \
87 -DENABLE_BUBBLEWRAP_SANDBOX=OFF \
88 -DENABLE_GAMEPAD=OFF \
89 "
90
91# Javascript JIT is not supported on ARC
92EXTRA_OECMAKE:append:arc = " -DENABLE_JIT=OFF "
93# By default 25-bit "medium" calls are used on ARC
94# which is not enough for binaries larger than 32 MiB
95CFLAGS:append:arc = " -mlong-calls"
96CXXFLAGS:append:arc = " -mlong-calls"
97
98# Needed for non-mesa graphics stacks when x11 is disabled
99CXXFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', '-DEGL_NO_X11=1', d)}"
100
101# Javascript JIT is not supported on powerpc
102EXTRA_OECMAKE:append:powerpc = " -DENABLE_JIT=OFF "
103EXTRA_OECMAKE:append:powerpc64 = " -DENABLE_JIT=OFF "
104
105# ARM JIT code does not build on ARMv4/5/6 anymore
106EXTRA_OECMAKE:append:armv5 = " -DENABLE_JIT=OFF "
107EXTRA_OECMAKE:append:armv6 = " -DENABLE_JIT=OFF "
108EXTRA_OECMAKE:append:armv4 = " -DENABLE_JIT=OFF "
109
110EXTRA_OECMAKE:append:mipsarch = " -DUSE_LD_GOLD=OFF "
111EXTRA_OECMAKE:append:powerpc = " -DUSE_LD_GOLD=OFF "
112
113# JIT and gold linker does not work on RISCV
114EXTRA_OECMAKE:append:riscv32 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
115EXTRA_OECMAKE:append:riscv64 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
116
117# JIT not supported on MIPS either
118EXTRA_OECMAKE:append:mipsarch = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON "
119
120# JIT not supported on X32
121# An attempt was made to upstream JIT support for x32 in
122# https://bugs.webkit.org/show_bug.cgi?id=100450, but this was closed as
123# unresolved due to limited X32 adoption.
124EXTRA_OECMAKE:append:x86-x32 = " -DENABLE_JIT=OFF "
125
126SECURITY_CFLAGS:remove:aarch64 = "-fpie"
127SECURITY_CFLAGS:append:aarch64 = " -fPIE"
128
129FILES:${PN} += "${libdir}/webkit2gtk-4.*/injected-bundle/libwebkit2gtkinjectedbundle.so"
130
131RRECOMMENDS:${PN} += "ca-certificates shared-mime-info"
132
133# http://errors.yoctoproject.org/Errors/Details/20370/
134ARM_INSTRUCTION_SET:armv4 = "arm"
135ARM_INSTRUCTION_SET:armv5 = "arm"
136ARM_INSTRUCTION_SET:armv6 = "arm"
137
138# https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474
139# https://bugs.webkit.org/show_bug.cgi?id=159880
140# JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime.
141# Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb).
142ARM_INSTRUCTION_SET:armv7a = "thumb"
143ARM_INSTRUCTION_SET:armv7r = "thumb"
144ARM_INSTRUCTION_SET:armv7ve = "thumb"
145
146# introspection inside qemu-arm hangs forever on musl/arm builds
147# therefore disable GI_DATA
148GI_DATA_ENABLED:libc-musl:armv7a = "False"
149GI_DATA_ENABLED:libc-musl:armv7ve = "False"
150
151# Can't be built with ccache
152CCACHE_DISABLE = "1"
153
154PACKAGE_PREPROCESS_FUNCS += "src_package_preprocess"
155src_package_preprocess () {
156 # Trim build paths from comments in generated sources to ensure reproducibility
157 sed -i -e "s,${WORKDIR},,g" \
158 ${B}/JavaScriptCore/DerivedSources/*.h \
159 ${B}/JavaScriptCore/DerivedSources/yarr/*.h \
160 ${B}/JavaScriptCore/PrivateHeaders/JavaScriptCore/*.h \
161 ${B}/WebKit2Gtk/DerivedSources/webkit2/*.cpp \
162 ${B}/WebKit2Gtk/DerivedSources/webkit2/*.h
163
164}
165