blob: d8ebeb64026aea0d48b344fd5d6c325083d3fd8a [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Convert text file line endings between CRLF and LF"
2DESCRIPTION = "The Dos2unix package includes utilities dos2unix and \
3unix2dos to convert plain text files in DOS or Mac format to Unix \
4format and vice versa."
5HOMEPAGE = "http://waterlan.home.xs4all.nl/dos2unix.html"
6SECTION = "support"
7
8LICENSE = "BSD-2-Clause"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -06009LIC_FILES_CHKSUM = "file://COPYING.txt;md5=37f72246ce2aa2fce9482c10b1f2b502"
Andrew Geissler82c905d2020-04-13 13:39:40 -050010
Andrew Geissler595f6302022-01-24 19:11:47 +000011SRC_URI = "git://git.code.sf.net/p/dos2unix/dos2unix;branch=master"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012UPSTREAM_CHECK_GITTAGREGEX = "dos2unix-(?P<pver>(\d+(\.\d+)+))"
13
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060014SRCREV = "b56a58584d3fef0720425ae154c2a4d80e6af6c5"
Andrew Geissler82c905d2020-04-13 13:39:40 -050015
16S = "${WORKDIR}/git/dos2unix"
17
18inherit gettext perlnative
19
20# The dos2unix NLS relies on po4a-native, while po4a recipe is
21# provided by meta-perl layer, so make it optional here, you
22# need have meta-perl in bblayers.conf before enabling nls in
23# PACKAGECONFIG.
24PACKAGECONFIG ??= ""
25PACKAGECONFIG[nls] = "ENABLE_NLS=1,ENABLE_NLS=,po4a-native"
26
27EXTRA_OEMAKE = "${PACKAGECONFIG_CONFARGS} LDFLAGS_USER='${LDFLAGS}'"
Patrick Williams213cb262021-08-07 19:21:33 -050028EXTRA_OEMAKE:class-native = "ENABLE_NLS="
Andrew Geissler82c905d2020-04-13 13:39:40 -050029
30do_install () {
31 oe_runmake DESTDIR="${D}${base_prefix}" install
32}
33
34BBCLASSEXTEND = "native nativesdk"