blob: affbccfe9de6c73f30acc69ff77a4d0bdeeab71d [file] [log] [blame]
Brad Bishop5f9be072016-06-27 14:53:52 -04001SUMMARY = "OpenBMC org.openbmc.control.Chassis example implementation"
2DESCRIPTION = "An example implementation of the org.openbmc.control.Chassis DBUS API."
3PR = "r1"
Patrick Venturea69d9ce2018-10-09 19:42:23 -07004PV = "1.0+git${SRCPV}"
Brad Bishop5f9be072016-06-27 14:53:52 -04005
6inherit skeleton-python
Brad Bishop1d525fa2016-08-17 20:27:37 -04007inherit obmc-phosphor-dbus-service
Brad Bishop5f9be072016-06-27 14:53:52 -04008
9RDEPENDS_${PN} += "\
10 python-dbus \
11 python-pygobject \
12 python-netclient \
Brad Bishop376b0652016-08-29 21:47:04 -040013 pyphosphor-dbus \
Brad Bishop5f9be072016-06-27 14:53:52 -040014 "
15
16SKELETON_DIR = "pychassisctl"
Brad Bishop1d525fa2016-08-17 20:27:37 -040017
18FMT = "org.openbmc.control.Chassis@{0}.service"
19DBUS_SERVICE_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"