Andrew Geissler | 7f40b71 | 2020-05-15 14:09:53 -0500 | [diff] [blame] | 1 | SUMMARY = "Berkeley TestFloat 3e" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 2 | DESCRIPTION = "Berkeley TestFloat is a small collection of programs for \ |
| 3 | testing that an implementation of binary floating-point conforms to the \ |
| 4 | IEEE Standard for Floating-Point Arithmetic." |
| 5 | |
| 6 | HOMEPAGE = "http://www.jhauser.us/arithmetic/TestFloat.html" |
| 7 | |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 8 | LICENSE = "BSD-3-Clause" |
Andrew Geissler | 7f40b71 | 2020-05-15 14:09:53 -0500 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://TestFloat-${PV}/COPYING.txt;md5=d467c2d231054347e8fd885ac06e7b2b" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 10 | |
| 11 | SRC_URI = "\ |
Andrew Geissler | 7f40b71 | 2020-05-15 14:09:53 -0500 | [diff] [blame] | 12 | http://www.jhauser.us/arithmetic/TestFloat-3e.zip;name=TestFloat \ |
| 13 | http://www.jhauser.us/arithmetic/SoftFloat-3e.zip;name=SoftFloat \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 14 | file://0001-Makefile-for-cross-compile-SoftFloat.patch \ |
| 15 | file://0002-Makefile-for-cross-compile-TestFloat.patch \ |
| 16 | " |
Andrew Geissler | 7f40b71 | 2020-05-15 14:09:53 -0500 | [diff] [blame] | 17 | SRC_URI[TestFloat.md5sum] = "e70a1e6c6732abf79645a6dcca69a654" |
| 18 | SRC_URI[TestFloat.sha256sum] = "6d4bdf0096b48a653aa59fc203a9e5fe18b5a58d7a1b715107c7146776a0aad6" |
| 19 | SRC_URI[SoftFloat.md5sum] = "7dac954ea4aed0697cbfee800ba4f492" |
| 20 | SRC_URI[SoftFloat.sha256sum] = "21130ce885d35c1fe73fc1e1bf2244178167e05c6747cad5f450cc991714c746" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 21 | |
| 22 | S = "${WORKDIR}" |
| 23 | |
| 24 | do_compile(){ |
| 25 | oe_runmake -C SoftFloat-${PV}/build/Linux-Cross-Compile/ |
| 26 | oe_runmake -C TestFloat-${PV}/build/Linux-Cross-Compile/ |
| 27 | } |
| 28 | |
| 29 | do_install(){ |
| 30 | install -d ${D}/${bindir} |
| 31 | install ${S}/TestFloat-${PV}/build/Linux-Cross-Compile/testfloat ${D}/${bindir} |
| 32 | install ${S}/TestFloat-${PV}/build/Linux-Cross-Compile/testfloat_gen ${D}/${bindir} |
| 33 | install ${S}/TestFloat-${PV}/build/Linux-Cross-Compile/testfloat_ver ${D}/${bindir} |
| 34 | install ${S}/TestFloat-${PV}/build/Linux-Cross-Compile/testsoftfloat ${D}/${bindir} |
| 35 | install ${S}/TestFloat-${PV}/build/Linux-Cross-Compile/timesoftfloat ${D}/${bindir} |
| 36 | } |