blob: 14eef9691988cbb9567d433ef96dabc4caa123b1 [file] [log] [blame]
Andrew Geisslerd688a012020-09-18 13:36:00 -05001SUMMARY = "A gevent based messagpack rpc library"
2DESCRIPTION = "mprpc is a fast implementation of the messagepack rpc protocol for python. \
3It is based on gevent for handling connections and enabling concurrent connections."
4HOMEPAGE = "https://github.com/studio-ousia/mprpc"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=4ba825394aec026b5f94edca44426859"
7DEPENDS += "${PYTHON_PN}-gevent"
8RDEPENDS_${PN} += "${PYTHON_PN}-gevent ${PYTHON_PN}-msgpack ${PYTHON_PN}-gsocketpool"
9
10SRC_URI[md5sum] = "8d97961051422f3de315613434982d3b"
11SRC_URI[sha256sum] = "3589fd127482e291b1ec314d6f0e55cc13311c12932ace356d6178ea1ca28f6a"
12
13inherit pypi setuptools3