blob: a26835b6079cd1a7bde97e2370d47531e4e17bfb [file] [log] [blame]
Andrew Geisslerc87764f2020-06-27 00:16:32 -05001SUMMARY = "Expose your Python functions to the command line with one easy step!"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=ea70b07c354e36056bd35e17c9c3face"
4
5inherit pypi setuptools3
6
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05007SRC_URI[md5sum] = "448635948823309312ea9f70b30b6c2d"
8SRC_URI[sha256sum] = "61f9ae9322e38ae64996848421afbdb018239a99c4e796fe064f172d6c98c3bf"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05009
10DEPENDS += "python3-setuptools-scm-native"
11RDEPENDS_${PN} += "\
12 python3-typing \
13 python3-dynamic-dispatch \
14 python3-typeguard \
15"
16
17BBCLASSEXTEND = "native nativesdk"