blob: a8df80fdd6c92b468da0c1c57fd23ef5389acac6 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "User support binary for the uvesafb kernel module"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06002HOMEPAGE = "https://tracker.debian.org/pkg/v86d"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05003
4# the copyright info is at the bottom of README, expect break
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://README;md5=94ac1971e4f2309dc322d598e7b1f7dd"
7
8DEPENDS = "virtual/kernel"
9RRECOMMENDS_${PN} = "kernel-module-uvesafb"
10PR = "r2"
11
Brad Bishop316dfdd2018-06-25 12:45:53 -040012SRC_URI = "http://snapshot.debian.org/archive/debian/20110427T035506Z/pool/main/v/${BPN}/${BPN}_${PV}.orig.tar.gz \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013 file://Update-x86emu-from-X.org.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060014 file://ar-from-env.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015 file://Support-for-cross-compilation.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060016"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018SRC_URI[md5sum] = "889686ec8424468fe0d205742e77a4c2"
19SRC_URI[sha256sum] = "93575c82e4307d8c4c370ec6b767f5cf87e527b2378146d652a6d8e25d5bdbc5"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050020
21PACKAGE_ARCH = "${MACHINE_ARCH}"
22COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
23
Patrick Williamsc124f4f2015-09-15 14:41:29 -050024do_configure () {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080025 TARGET_ARCH="${TARGET_ARCH}" ./configure --with-x86emu
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026}
27
28do_compile () {
29 KDIR="${STAGING_DIR_HOST}/usr" make
30}
31
32do_install () {
33 install -d ${D}${base_sbindir}
34 install v86d ${D}${base_sbindir}/
Patrick Williamsc124f4f2015-09-15 14:41:29 -050035}