blob: abaa8149a31ae11e6e2ad27608a7c3bb3a39f6ed [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "File classification tool"
2DESCRIPTION = "File attempts to classify files depending \
3on their contents and prints a description if a match is found."
4HOMEPAGE = "http://www.darwinsys.com/file/"
5SECTION = "console/utils"
6
7# two clause BSD
8LICENSE = "BSD-2-Clause"
9LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=0251eaec1188b20d9a72c502ecfdda1b"
10
Andrew Geisslerc182c622020-05-15 14:13:32 -050011DEPENDS = "file-replacement-native"
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050012DEPENDS_class-native = "bzip2-replacement-native"
Andrew Geissler82c905d2020-04-13 13:39:40 -050013
Andrew Geissler6ce62a22020-11-30 19:58:47 -060014SRC_URI = "git://github.com/file/file.git \
15 file://0001-src-compress.c-correct-header-define-for-xz-lzma.patch"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016
Andrew Geisslerd25ed322020-06-27 00:28:28 -050017SRCREV = "87731415de945660b00f02207d8e9d986ef9b82e"
Andrew Geissler82c905d2020-04-13 13:39:40 -050018S = "${WORKDIR}/git"
19
20inherit autotools update-alternatives
21
Andrew Geissler6ce62a22020-11-30 19:58:47 -060022PACKAGECONFIG ??= "bz2 lzma zlib"
Andrew Geisslerc182c622020-05-15 14:13:32 -050023PACKAGECONFIG[bz2] = "--enable-bzlib, --disable-bzlib, bzip2"
24PACKAGECONFIG[lzma] = "--enable-xzlib, --disable-xzlib, xz"
25PACKAGECONFIG[zlib] = "--enable-zlib, --disable-zlib, zlib"
26
Andrew Geissler82c905d2020-04-13 13:39:40 -050027EXTRA_OECONF += "--disable-libseccomp"
28
29ALTERNATIVE_${PN} = "file"
30ALTERNATIVE_LINK_NAME[file] = "${bindir}/file"
31
32EXTRA_OEMAKE_append_class-target = " -e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file"
33EXTRA_OEMAKE_append_class-nativesdk = " -e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file"
34
35FILES_${PN} += "${datadir}/misc/*.mgc"
36
37do_compile_append_class-native() {
38 oe_runmake check
39}
40
41do_install_append_class-native() {
42 create_cmdline_wrapper ${D}/${bindir}/file \
43 --magic-file ${datadir}/misc/magic.mgc
44}
45
46do_install_append_class-nativesdk() {
47 create_cmdline_wrapper ${D}/${bindir}/file \
48 --magic-file ${datadir}/misc/magic.mgc
49}
50
51BBCLASSEXTEND = "native nativesdk"
52PROVIDES_append_class-native = " file-replacement-native"
53# Don't use NATIVE_PACKAGE_PATH_SUFFIX as that hides libmagic from anyone who
54# depends on file-replacement-native.
55bindir_append_class-native = "/file-native"