blob: 2bfc913aa0ac686a443a91db1152050d43c4572c [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "A sophisticated Numeric Processing Package for Python"
2SECTION = "devel/python"
Brad Bishop79641f22019-09-10 07:20:22 -04003LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF & Apache-2.0 & BSD & MIT"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06004LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e527e2a94c4584cd192d03ffb1f4a744"
Brad Bishop316dfdd2018-06-25 12:45:53 -04005
6SRCNAME = "numpy"
7
8SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
9 file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060010 file://0001-numpy-core-Define-RISCV-32-support.patch \
11 file://run-ptest \
12"
13SRC_URI[sha256sum] = "fe836a685d6838dbb3f603caef01183ea98e88febf4ce956a2ea484a75378413"
Brad Bishop316dfdd2018-06-25 12:45:53 -040014
15UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases"
16UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
17
Andrew Geissler82c905d2020-04-13 13:39:40 -050018DEPENDS += "python3-cython-native"
19
Andrew Geissler6ce62a22020-11-30 19:58:47 -060020inherit ptest setuptools3
21
Brad Bishop316dfdd2018-06-25 12:45:53 -040022S = "${WORKDIR}/numpy-${PV}"
23
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080024CLEANBROKEN = "1"
25
Andrew Geissler475cb722020-07-10 16:00:51 -050026FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a"
Brad Bishop316dfdd2018-06-25 12:45:53 -040027
28# install what is needed for numpy.test()
29RDEPENDS_${PN} = "${PYTHON_PN}-unittest \
30 ${PYTHON_PN}-difflib \
31 ${PYTHON_PN}-pprint \
32 ${PYTHON_PN}-pickle \
33 ${PYTHON_PN}-shell \
Brad Bishop316dfdd2018-06-25 12:45:53 -040034 ${PYTHON_PN}-doctest \
35 ${PYTHON_PN}-datetime \
36 ${PYTHON_PN}-distutils \
37 ${PYTHON_PN}-misc \
38 ${PYTHON_PN}-mmap \
39 ${PYTHON_PN}-netclient \
40 ${PYTHON_PN}-numbers \
41 ${PYTHON_PN}-pydoc \
42 ${PYTHON_PN}-pkgutil \
43 ${PYTHON_PN}-email \
44 ${PYTHON_PN}-compression \
45 ${PYTHON_PN}-ctypes \
46 ${PYTHON_PN}-threading \
Brad Bishop79641f22019-09-10 07:20:22 -040047 ${PYTHON_PN}-multiprocessing \
Brad Bishop316dfdd2018-06-25 12:45:53 -040048"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060049RDEPENDS_${PN}-ptest += "${PYTHON_PN}-pytest \
50 ${PYTHON_PN}-hypothesis \
51 ${PYTHON_PN}-sortedcontainers \
52 ${PYTHON_PN}-resource \
53 ldd \
54"
Brad Bishop316dfdd2018-06-25 12:45:53 -040055
56RDEPENDS_${PN}_class-native = ""
57
58BBCLASSEXTEND = "native nativesdk"