blob: 9005bdea59beaf8def4c08793eece5c33d83ce0c [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Convert text file line endings between CRLF and LF"
2DESCRIPTION = "The Dos2unix package includes utilities dos2unix and \
3unix2dos to convert plain text files in DOS or Mac format to Unix \
4format and vice versa."
5HOMEPAGE = "http://waterlan.home.xs4all.nl/dos2unix.html"
6SECTION = "support"
7
8LICENSE = "BSD-2-Clause"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06009LIC_FILES_CHKSUM = "file://COPYING.txt;md5=8a7c3499a1142df819e727253cd53a12"
Andrew Geissler82c905d2020-04-13 13:39:40 -050010
11SRC_URI = "git://git.code.sf.net/p/dos2unix/dos2unix"
12UPSTREAM_CHECK_GITTAGREGEX = "dos2unix-(?P<pver>(\d+(\.\d+)+))"
13
Andrew Geissler6ce62a22020-11-30 19:58:47 -060014SRCREV = "72596f0ae21faa25a07a872d4843bc885475115d"
Andrew Geissler82c905d2020-04-13 13:39:40 -050015
16S = "${WORKDIR}/git/dos2unix"
17
18inherit gettext perlnative
19
20# The dos2unix NLS relies on po4a-native, while po4a recipe is
21# provided by meta-perl layer, so make it optional here, you
22# need have meta-perl in bblayers.conf before enabling nls in
23# PACKAGECONFIG.
24PACKAGECONFIG ??= ""
25PACKAGECONFIG[nls] = "ENABLE_NLS=1,ENABLE_NLS=,po4a-native"
26
27EXTRA_OEMAKE = "${PACKAGECONFIG_CONFARGS} LDFLAGS_USER='${LDFLAGS}'"
28EXTRA_OEMAKE_class-native = "ENABLE_NLS="
29
30do_install () {
31 oe_runmake DESTDIR="${D}${base_prefix}" install
32}
33
34BBCLASSEXTEND = "native nativesdk"