blob: 5b32b9af41f3e2252512e0e7300ed13b70bc857c [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001# Copyright (C) 2013 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Library of utility functions from BSD systems"
5DESCRIPTION = "This library provides useful functions commonly found on BSD systems, \
6 and lacking on others like GNU systems, thus making it easier to port \
7 projects with strong BSD origins, without needing to embed the same \
8 code over and over again on each project."
9
Andrew Geissler82c905d2020-04-13 13:39:40 -050010HOMEPAGE = "https://libbsd.freedesktop.org/wiki/"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011# There seems to be more licenses used in the code, I don't think we want to list them all here, complete list:
12# OE @ ~/projects/libbsd $ grep ^License: COPYING | sort -u
13# License: BSD-2-clause
14# License: BSD-2-clause-NetBSD
15# License: BSD-2-clause-author
16# License: BSD-2-clause-verbatim
17# License: BSD-3-clause
18# License: BSD-3-clause-author
19# License: BSD-3-clause-John-Birrell
20# License: BSD-3-clause-Regents
21# License: BSD-4-clause-Christopher-G-Demetriou
22# License: BSD-4-clause-Niels-Provos
23# License: BSD-5-clause-Peter-Wemm
24# License: Beerware
25# License: Expat
26# License: ISC
27# License: ISC-Original
28# License: public-domain
29# License: public-domain-Colin-Plumb
Andrew Geissler6ce62a22020-11-30 19:58:47 -060030LICENSE = "BSD-3-Clause & BSD-4-Clause & ISC & PD"
31LICENSE_${PN} = "BSD-3-Clause & ISC & PD"
Brad Bishop79641f22019-09-10 07:20:22 -040032LIC_FILES_CHKSUM = "file://COPYING;md5=2120be0173469a06ed185b688e0e1ae0"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080033SECTION = "libs"
34
Andrew Geissler82c905d2020-04-13 13:39:40 -050035SRC_URI = "https://libbsd.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080036
Brad Bishop79641f22019-09-10 07:20:22 -040037SRC_URI[md5sum] = "ead96d240d02faa5b921c0aa50c812b5"
38SRC_URI[sha256sum] = "34b8adc726883d0e85b3118fa13605e179a62b31ba51f676136ecb2d0bc1a887"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080039
40inherit autotools pkgconfig
41
42BBCLASSEXTEND = "native nativesdk"