blob: b5bdcd5b19e20c25421fcc8eef9f4aa6c1c4f855 [file] [log] [blame]
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -05001SUMMARY = "C-Periphery lib used to access GPIO, LED, PWM, SPI, I2C, MMIO, Serial"
Andrew Geissler89770b02020-06-13 10:40:47 -05002DESCRIPTION = "A C library for peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO, Serial) in Linux"
3
4HOMEPAGE = "https://github.com/vsergeev/c-periphery"
5
6SECTION = "libs"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=4097ec544cf01e9c7cfc4bdf8e4ed887"
10
Andrew Geissler595f6302022-01-24 19:11:47 +000011SRC_URI = "git://github.com/vsergeev/c-periphery;protocol=https;branch=master"
Andrew Geisslereef63862021-01-29 15:58:13 -060012SRCREV = "23bfa4ab481edbad82a69ee385fc58ce03b63084"
Andrew Geissler89770b02020-06-13 10:40:47 -050013
14S = "${WORKDIR}/git"
15
16inherit cmake
17
18EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON"
19
20BBCLASSEXTEND = "native nativesdk"
21