blob: 75a41e29dcb8927e44e6991e1b471cd16021d1d8 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Provides both a high- and low-level interface to the HDF5 library from Python."
2HOMEPAGE = "https://www.h5py.org/"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=113251d71fb0384712c719b567261c5c"
6
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05007SRC_URI[sha256sum] = "6fead82f0c4000cf38d53f9c030780d81bfa0220218aee13b90b7701c937d95f"
Andrew Geissler9aee5002022-03-30 16:27:02 +00008
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05009SRC_URI += "file://0001-setup_build.py-avoid-absolute-path.patch"
Andrew Geissler9aee5002022-03-30 16:27:02 +000010
11inherit pkgconfig pypi setuptools3
12
13BBCLASSEXTEND = "native"
14
15DEPENDS = "python3-pkgconfig-native \
16 python3-cython-native \
17 python3-numpy-native \
18 python3-six-native \
19 hdf5-native \
20 python3 \
21 hdf5 \
22 "
23
24RDEPENDS:${PN} = "python3-numpy \
25 python3-six \
26 python3-json \
27 "
28
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050029export HDF5_VERSION="1.14.0"