blob: f4c6d9511dbc2a26e1540ff76646ba9252a4d168 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Rust compiler and runtime libaries"
2HOMEPAGE = "http://www.rust-lang.org"
3SECTION = "devel"
4LICENSE = "(MIT | Apache-2.0) & Unicode-TOU"
Patrick Williams864cc432023-02-09 14:54:44 -06005LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=c2cccf560306876da3913d79062a54b9"
Andrew Geissler517393d2023-01-13 08:55:19 -06006
7inherit rust
8inherit cargo_common
9
10DEPENDS += "file-native python3-native"
11DEPENDS:append:class-native = " rust-llvm-native"
12DEPENDS:append:class-nativesdk = " nativesdk-rust-llvm"
13
14DEPENDS += "rust-llvm (=${PV})"
15
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050016RDEPENDS:${PN}:append:class-target = " gcc g++ binutils"
17
Andrew Geissler517393d2023-01-13 08:55:19 -060018# Otherwise we'll depend on what we provide
19INHIBIT_DEFAULT_RUST_DEPS:class-native = "1"
20# We don't need to depend on gcc-native because yocto assumes it exists
21PROVIDES:class-native = "virtual/${TARGET_PREFIX}rust"
22
23S = "${RUSTSRC}"
24
25# Use at your own risk, accepted values are stable, beta and nightly
26RUST_CHANNEL ?= "stable"
27PV .= "${@bb.utils.contains('RUST_CHANNEL', 'stable', '', '-${RUST_CHANNEL}', d)}"
28
29export FORCE_CRATE_HASH="${BB_TASKHASH}"
30
31RUST_ALTERNATE_EXE_PATH ?= "${STAGING_LIBDIR}/llvm-rust/bin/llvm-config"
32RUST_ALTERNATE_EXE_PATH_NATIVE = "${STAGING_LIBDIR_NATIVE}/llvm-rust/bin/llvm-config"
33
34# We don't want to use bitbakes vendoring because the rust sources do their
35# own vendoring.
36CARGO_DISABLE_BITBAKE_VENDORING = "1"
37
38# We can't use RUST_BUILD_SYS here because that may be "musl" if
39# TCLIBC="musl". Snapshots are always -unknown-linux-gnu
40setup_cargo_environment () {
41 # The first step is to build bootstrap and some early stage tools,
42 # these are build for the same target as the snapshot, e.g.
43 # x86_64-unknown-linux-gnu.
44 # Later stages are build for the native target (i.e. target.x86_64-linux)
45 cargo_common_do_configure
46}
47
48inherit rust-target-config
49
50do_rust_setup_snapshot () {
51 for installer in "${WORKDIR}/rust-snapshot-components/"*"/install.sh"; do
52 "${installer}" --prefix="${WORKDIR}/rust-snapshot" --disable-ldconfig
53 done
54
55 # Some versions of rust (e.g. 1.18.0) tries to find cargo in stage0/bin/cargo
56 # and fail without it there.
57 mkdir -p ${RUSTSRC}/build/${BUILD_SYS}
58 ln -sf ${WORKDIR}/rust-snapshot/ ${RUSTSRC}/build/${BUILD_SYS}/stage0
59
60 # Need to use uninative's loader if enabled/present since the library paths
61 # are used internally by rust and result in symbol mismatches if we don't
62 if [ ! -z "${UNINATIVE_LOADER}" -a -e "${UNINATIVE_LOADER}" ]; then
63 for bin in cargo rustc rustdoc; do
64 patchelf-uninative ${WORKDIR}/rust-snapshot/bin/$bin --set-interpreter ${UNINATIVE_LOADER}
65 done
66 fi
67}
68addtask rust_setup_snapshot after do_unpack before do_configure
69do_rust_setup_snapshot[dirs] += "${WORKDIR}/rust-snapshot"
70do_rust_setup_snapshot[vardepsexclude] += "UNINATIVE_LOADER"
71
72python do_configure() {
73 import json
74 try:
75 import configparser
76 except ImportError:
77 import ConfigParser as configparser
78
79 # toml is rather similar to standard ini like format except it likes values
80 # that look more JSON like. So for our purposes simply escaping all values
81 # as JSON seem to work fine.
82
83 e = lambda s: json.dumps(s)
84
85 config = configparser.RawConfigParser()
86
87 # [target.ARCH-poky-linux]
Patrick Williams864cc432023-02-09 14:54:44 -060088 host_section = "target.{}".format(d.getVar('RUST_HOST_SYS'))
Andrew Geissler517393d2023-01-13 08:55:19 -060089 config.add_section(host_section)
90
91 llvm_config_target = d.expand("${RUST_ALTERNATE_EXE_PATH}")
92 llvm_config_build = d.expand("${RUST_ALTERNATE_EXE_PATH_NATIVE}")
93 config.set(host_section, "llvm-config", e(llvm_config_target))
94
95 config.set(host_section, "cxx", e(d.expand("${RUST_TARGET_CXX}")))
96 config.set(host_section, "cc", e(d.expand("${RUST_TARGET_CC}")))
97 config.set(host_section, "linker", e(d.expand("${RUST_TARGET_CCLD}")))
98 if "musl" in host_section:
99 config.set(host_section, "musl-root", e(d.expand("${STAGING_DIR_HOST}${exec_prefix}")))
100
101 # If we don't do this rust-native will compile it's own llvm for BUILD.
102 # [target.${BUILD_ARCH}-unknown-linux-gnu]
Patrick Williams864cc432023-02-09 14:54:44 -0600103 build_section = "target.{}".format(d.getVar('RUST_BUILD_SYS'))
Andrew Geissler517393d2023-01-13 08:55:19 -0600104 if build_section != host_section:
105 config.add_section(build_section)
106
107 config.set(build_section, "llvm-config", e(llvm_config_build))
108
109 config.set(build_section, "cxx", e(d.expand("${RUST_BUILD_CXX}")))
110 config.set(build_section, "cc", e(d.expand("${RUST_BUILD_CC}")))
111 config.set(build_section, "linker", e(d.expand("${RUST_BUILD_CCLD}")))
112
Patrick Williams864cc432023-02-09 14:54:44 -0600113 target_section = "target.{}".format(d.getVar('RUST_TARGET_SYS'))
Andrew Geissler517393d2023-01-13 08:55:19 -0600114 if target_section != host_section and target_section != build_section:
115 config.add_section(target_section)
116
117 config.set(target_section, "llvm-config", e(llvm_config_target))
118
119 config.set(target_section, "cxx", e(d.expand("${RUST_TARGET_CXX}")))
120 config.set(target_section, "cc", e(d.expand("${RUST_TARGET_CC}")))
121 config.set(target_section, "linker", e(d.expand("${RUST_TARGET_CCLD}")))
122
123 # [llvm]
124 config.add_section("llvm")
125 config.set("llvm", "static-libstdcpp", e(False))
126 if "llvm" in (d.getVar('TC_CXX_RUNTIME') or ""):
127 config.set("llvm", "use-libcxx", e(True))
128
129 # [rust]
130 config.add_section("rust")
131 config.set("rust", "rpath", e(True))
132 config.set("rust", "channel", e(d.expand("${RUST_CHANNEL}")))
133
134 # Whether or not to optimize the compiler and standard library
135 config.set("rust", "optimize", e(True))
136
137 # Emits extraneous output from tests to ensure that failures of the test
138 # harness are debuggable just from logfiles
139 config.set("rust", "verbose-tests", e(True))
140
141 # [build]
142 config.add_section("build")
143 config.set("build", "submodules", e(False))
144 config.set("build", "docs", e(False))
145
146 rustc = d.expand("${WORKDIR}/rust-snapshot/bin/rustc")
147 config.set("build", "rustc", e(rustc))
148
149 # Support for the profiler runtime to generate e.g. coverage report,
150 # PGO etc.
151 config.set("build", "profiler", e(True))
152
153 cargo = d.expand("${WORKDIR}/rust-snapshot/bin/cargo")
154 config.set("build", "cargo", e(cargo))
155
156 config.set("build", "vendor", e(True))
157
158 if not "targets" in locals():
Patrick Williams864cc432023-02-09 14:54:44 -0600159 targets = [d.getVar("RUST_TARGET_SYS")]
Andrew Geissler517393d2023-01-13 08:55:19 -0600160 config.set("build", "target", e(targets))
161
162 if not "hosts" in locals():
Patrick Williams864cc432023-02-09 14:54:44 -0600163 hosts = [d.getVar("RUST_HOST_SYS")]
Andrew Geissler517393d2023-01-13 08:55:19 -0600164 config.set("build", "host", e(hosts))
165
166 # We can't use BUILD_SYS since that is something the rust snapshot knows
167 # nothing about when trying to build some stage0 tools (like fabricate)
Patrick Williams864cc432023-02-09 14:54:44 -0600168 config.set("build", "build", e(d.getVar("RUST_BUILD_SYS")))
Andrew Geissler517393d2023-01-13 08:55:19 -0600169
170 # [install]
171 config.add_section("install")
172 # ./x.py install doesn't have any notion of "destdir"
173 # but we can prepend ${D} to all the directories instead
Patrick Williams864cc432023-02-09 14:54:44 -0600174 config.set("install", "prefix", e(d.getVar("D") + d.getVar("prefix")))
175 config.set("install", "bindir", e(d.getVar("D") + d.getVar("bindir")))
176 config.set("install", "libdir", e(d.getVar("D") + d.getVar("libdir")))
177 config.set("install", "datadir", e(d.getVar("D") + d.getVar("datadir")))
178 config.set("install", "mandir", e(d.getVar("D") + d.getVar("mandir")))
Andrew Geissler517393d2023-01-13 08:55:19 -0600179
180 with open("config.toml", "w") as f:
181 f.write('changelog-seen = 2\n\n')
182 config.write(f)
183
184 # set up ${WORKDIR}/cargo_home
185 bb.build.exec_func("setup_cargo_environment", d)
186}
187
188rust_runx () {
189 echo "COMPILE ${PN}" "$@"
190
191 # CFLAGS, LDFLAGS, CXXFLAGS, CPPFLAGS are used by rust's build for a
192 # wide range of targets (not just TARGET). Yocto's settings for them will
193 # be inappropriate, avoid using.
194 unset CFLAGS
195 unset LDFLAGS
196 unset CXXFLAGS
197 unset CPPFLAGS
198
199 export RUSTFLAGS="${RUST_DEBUG_REMAP}"
200
201 # Copy the natively built llvm-config into the target so we can run it. Horrible,
202 # but works!
203 if [ ${RUST_ALTERNATE_EXE_PATH_NATIVE} != ${RUST_ALTERNATE_EXE_PATH} ]; then
204 mkdir -p `dirname ${RUST_ALTERNATE_EXE_PATH}`
205 cp ${RUST_ALTERNATE_EXE_PATH_NATIVE} ${RUST_ALTERNATE_EXE_PATH}
206 chrpath -d ${RUST_ALTERNATE_EXE_PATH}
207 fi
208
209 oe_cargo_fix_env
210
211 python3 src/bootstrap/bootstrap.py ${@oe.utils.parallel_make_argument(d, '-j %d')} "$@" --verbose
212}
213rust_runx[vardepsexclude] += "PARALLEL_MAKE"
214
215require rust-source.inc
216require rust-snapshot.inc
217
218INSANE_SKIP:${PN}:class-native = "already-stripped"
219FILES:${PN} += "${libdir}/rustlib"
220FILES:${PN} += "${libdir}/*.so"
221FILES:${PN}-dev = ""
222
223do_compile () {
224 rust_runx build --stage 2
225}
226
227do_compile:append:class-target () {
228 rust_runx build --stage 2 src/tools/clippy
229 rust_runx build --stage 2 src/tools/rustfmt
230}
231
232do_compile:append:class-nativesdk () {
233 rust_runx build --stage 2 src/tools/clippy
234 rust_runx build --stage 2 src/tools/rustfmt
235}
236
237ALLOW_EMPTY:${PN} = "1"
238
239PACKAGES =+ "${PN}-tools-clippy ${PN}-tools-rustfmt"
240FILES:${PN}-tools-clippy = "${bindir}/cargo-clippy ${bindir}/clippy-driver"
241FILES:${PN}-tools-rustfmt = "${bindir}/rustfmt"
242RDEPENDS:${PN}-tools-clippy = "${PN}"
243RDEPENDS:${PN}-tools-rustfmt = "${PN}"
244
245SUMMARY:${PN}-tools-clippy = "A collection of lints to catch common mistakes and improve your Rust code"
246SUMMARY:${PN}-tools-rustfmt = "A tool for formatting Rust code according to style guidelines"
247
248do_install () {
249 rust_do_install
250}
251
252rust_do_install() {
253 rust_runx install
254}
255
256rust_do_install:class-nativesdk() {
257 export PSEUDO_UNLOAD=1
258 rust_runx install
259 unset PSEUDO_UNLOAD
260
261 install -d ${D}${bindir}
262 for i in cargo-clippy clippy-driver rustfmt; do
263 cp build/${RUST_BUILD_SYS}/stage2-tools/${RUST_HOST_SYS}/release/$i ${D}${bindir}
264 chrpath -r "\$ORIGIN/../lib" ${D}${bindir}/$i
265 done
266
267 chown root:root ${D}/ -R
268 rm ${D}${libdir}/rustlib/uninstall.sh
269 rm ${D}${libdir}/rustlib/install.log
270 rm ${D}${libdir}/rustlib/manifest*
271}
272
273EXTRA_TOOLS ?= "cargo-clippy clippy-driver rustfmt"
274rust_do_install:class-target() {
275 export PSEUDO_UNLOAD=1
276 rust_runx install
277 unset PSEUDO_UNLOAD
278
279 install -d ${D}${bindir}
280 for i in ${EXTRA_TOOLS}; do
281 cp build/${RUST_BUILD_SYS}/stage2-tools/${RUST_HOST_SYS}/release/$i ${D}${bindir}
282 chrpath -r "\$ORIGIN/../lib" ${D}${bindir}/$i
283 done
284
285 install -d ${D}${libdir}/rustlib/${RUST_HOST_SYS}
286 install -m 0644 ${WORKDIR}/rust-targets/${RUST_HOST_SYS}.json ${D}${libdir}/rustlib/${RUST_HOST_SYS}/target.json
287
288 chown root:root ${D}/ -R
289 rm ${D}${libdir}/rustlib/uninstall.sh
290 rm ${D}${libdir}/rustlib/install.log
291 rm ${D}${libdir}/rustlib/manifest*
292}
293
Patrick Williams864cc432023-02-09 14:54:44 -0600294addtask do_update_snapshot after do_patch
295do_update_snapshot[nostamp] = "1"
296
297# Run with `bitbake -c update_snapshot rust` to update `rust-snapshot.inc`
298# with the checksums for the rust snapshot associated with this rustc-src
299# tarball.
300python do_update_snapshot() {
301 import json
302 import re
303 import sys
304
305 from collections import defaultdict
306
307 with open(os.path.join(d.getVar("S"), "src", "stage0.json")) as f:
308 j = json.load(f)
309
310 config_dist_server = j['config']['dist_server']
311 compiler_date = j['compiler']['date']
312 compiler_version = j['compiler']['version']
313
314 src_uri = defaultdict(list)
315 for k, v in j['checksums_sha256'].items():
316 m = re.search(f"dist/{compiler_date}/(?P<component>.*)-{compiler_version}-(?P<arch>.*)-unknown-linux-gnu\\.tar\\.xz", k)
317 if m:
318 component = m.group('component')
319 arch = m.group('arch')
320 src_uri[arch].append(f"SRC_URI[{component}-snapshot-{arch}.sha256sum] = \"{v}\"")
321
322 snapshot = """\
323## This is information on the rust-snapshot (binary) used to build our current release.
324## snapshot info is taken from rust/src/stage0.json
325## Rust is self-hosting and bootstraps itself with a pre-built previous version of itself.
326## The exact (previous) version that has been used is specified in the source tarball.
327## The version is replicated here.
328
329SNAPSHOT_VERSION = "%s"
330
331""" % compiler_version
332
333 for arch, components in src_uri.items():
334 snapshot += "\n".join(components) + "\n\n"
335
336 snapshot += """\
337SRC_URI += " \\
338 ${RUST_DIST_SERVER}/dist/${RUST_STD_SNAPSHOT}.tar.xz;name=rust-std-snapshot-${RUST_BUILD_ARCH};subdir=rust-snapshot-components \\
339 ${RUST_DIST_SERVER}/dist/${RUSTC_SNAPSHOT}.tar.xz;name=rustc-snapshot-${RUST_BUILD_ARCH};subdir=rust-snapshot-components \\
340 ${RUST_DIST_SERVER}/dist/${CARGO_SNAPSHOT}.tar.xz;name=cargo-snapshot-${RUST_BUILD_ARCH};subdir=rust-snapshot-components \\
341"
342
343RUST_DIST_SERVER = "%s"
344
345RUST_STD_SNAPSHOT = "rust-std-${SNAPSHOT_VERSION}-${RUST_BUILD_ARCH}-unknown-linux-gnu"
346RUSTC_SNAPSHOT = "rustc-${SNAPSHOT_VERSION}-${RUST_BUILD_ARCH}-unknown-linux-gnu"
347CARGO_SNAPSHOT = "cargo-${SNAPSHOT_VERSION}-${RUST_BUILD_ARCH}-unknown-linux-gnu"
348""" % config_dist_server
349
350 with open(os.path.join(d.getVar("THISDIR"), "rust-snapshot.inc"), "w") as f:
351 f.write(snapshot)
352}
353
Andrew Geissler517393d2023-01-13 08:55:19 -0600354RUSTLIB_DEP:class-nativesdk = ""
355
356# musl builds include libunwind.a
357INSANE_SKIP:${PN} = "staticdev"
358
359BBCLASSEXTEND = "native nativesdk"